PAT-A-1056 Mice and Rice

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N
​P
​​ programmers. Then every N
​G
​​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N
​G
​​ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N
​P
​​ and N
​G
​​ (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N
​G
​​ mice at the end of the player’s list, then all the mice left will be put into the last group. The second line contains N
​P
​​ distinct non-negative numbers W
​i
​​ (i=0,⋯,N
​P
​​ −1) where each W
​i
​​ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,N
​P
​​ −1 (assume that the programmers are numbered from 0 to N
​P
​​ −1). All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3
Sample Output:
5 5 5 2 5 5 5 3 1 3 5
代码如下:

#include <iostream>
#include <algorithm>
#include <vector>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <string.h>
#include <math.h>
using namespace std;
const int maxn=1010;
struct  MOUSE{
    int weight;//老鼠
    int R;//排名
}mouse[maxn];
int main(){
    int np,ng,order;
    scanf("%d%d",&np,&ng);//总人数和每轮人数
    for(int i = 0 ; i < np ; i ++){
        scanf("%d",&mouse[i].weight);
    }
    queue<int> q;//定义一个队列
    for(int i = 0 ; i < np ; i ++){
        scanf("%d",&order);//题目给的顺序
        q.push(order);//按顺序把老鼠们的标号入队
    }
    int temp=np,group;//temp为当前轮的比赛总老鼠数,group为组数
    while(q.size()!=1){
        if(temp%ng==0){
            group=temp/ng;
        }else{
            group=temp/ng+1;
        }
        //枚举每一个组,选出改组中体重最大的老鼠
        for(int i = 0 ; i < group ; i ++){
            int k=q.front();//k存放在该组质量最大的老鼠编号
            for(int j = 0 ; j < ng  ; j ++){
                //最后一组老鼠数不足ng时退出循环
                if(i*ng+j>=temp){
                    break;
                }
                int front =q.front();//取队首老鼠的编号
                if(mouse[k].weight<mouse[front].weight){
                    k=front;//找出质量最大的那只老鼠
                }
                mouse[front].R=group+1;//被淘汰的那只老鼠排名确定
                q.pop();//将这只老鼠的编号探出队列
            }
            q.push(k);//这一轮的胜者继续留在队列中
        }
        temp=group;//下一轮的总人数为这一轮的总组数(每一组晋级一个)
    }
    mouse[q.front()].R=1;//当队列中只剩一个老鼠时,令其排名为1
    for(int i = 0 ; i < np ; i ++){
        cout<<mouse[i].R;
        if(i<np-1){
            cout<<" ";
        }
    }
    // system("pause");
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值