PAT-A-1094 The Largest Generation【DFS+BFS】

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:
Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID’s of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
Sample Output:
9 4
本题用dfs和bfs都可以,dfs相对更简洁,bfs拿来练手了
DFS版本代码如下:

#include <iostream>
#include <algorithm>
#include <vector>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <string.h>
#include <math.h>
using namespace std;
const int maxn=105;
int hashTable[maxn]={0};//记录每层的结点个数;
vector<int >Node[maxn];//树的的静态写法,Node[i]存放结点i的孩子结点编号
void DFS(int index,int depth){
    hashTable[depth]++;//第level层的结点个数加1
    for(int j = 0 ; j < Node[index].size() ; j ++){
        DFS(Node[index][j],depth+1);//遍历所有孩子结点,进行递归
    }
}
int main(){
    int n,m;
    scanf("%d%d",&n,&m);
    int parent,k,child;
    for(int i = 0 ; i < m ; i ++){
        scanf("%d%d",&parent,&k);
        for(int j = 0 ; j < k ; j ++){
            scanf("%d",&child);
            Node[parent].push_back(child);
        }
    }
    DFS(1,1);
    int maxNum=-1,maxLevel;
    for(int i = 0 ; i < maxn ; i ++){
        if(maxNum<hashTable[i]){
            maxNum=hashTable[i];
            maxLevel=i;
        }
    }
    printf("%d %d\n",maxNum,maxLevel);
    // system("pause");
    return 0;
}

BFS代码如下:

#include <iostream>
#include <algorithm>
#include <vector>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <string.h>
#include <math.h>
using namespace std;
const int maxn=105;
struct node
{
    int level;
    vector<int> child;
}Node[maxn];

int hashTable[maxn]={0};
void BFS(int root){
    queue<int> q;
    q.push(root);
    while(!q.empty()){
        int now=q.front();
        q.pop();
        hashTable[Node[now].level]++;
        for(int i = 0 ; i < Node[now].child.size() ; i ++){
            Node[Node[now].child[i]].level=Node[now].level+1;
            q.push(Node[now].child[i]);
        }
    }

}
void init(){
    for(int i = 0 ; i < maxn ; i ++){
        Node[i].level=1;
    }
}
int main(){
    init();
    int n,m;
    scanf("%d%d",&n,&m);
    int parent,k,child;
    for(int i = 0 ; i < m ; i ++){
        scanf("%d%d",&parent,&k);
        for(int j = 0 ; j < k ; j ++){
            scanf("%d",&child);
            Node[parent].child.push_back(child);
        }
    }
    BFS(1);
    int maxNum=-1,maxLevel;
    for(int i = 0 ; i < maxn ; i ++){
        if(maxNum<hashTable[i]){
            maxNum=hashTable[i];
            maxLevel=i;
        }
    }
    printf("%d %d\n",maxNum,maxLevel);
    // system("pause");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值