【PAT】A1100 Mars Numbers *

People on Mars count their numbers with base 13:

  • Zero on Earth is called "tret" on Mars.
  • The numbers 1 to 12 on Earth is called "jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec" on Mars, respectively.
  • For the next higher digit, Mars people name the 12 numbers as "tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou", respectively.

For examples, the number 29 on Earth is called "hel mar" on Mars; and "elo nov" on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:

For each number, print in a line the corresponding number in the other language.

Sample Input:

4
29
5
elo nov
tam

Sample Output:

hel mar
may
115
13

解题思路:

  1. 理解题意:也是一种进制的转变,但是需要用到映射
  2. 代码分为两段:首先是初始化映射,然后根据输入的判断,处理输出。
  3. 总结:本题的难点在于初始化的函数,就是整型转变为

代码:

#include <stdio.h>
#include <map>
#include <string>
#include <iostream>
#include <string.h>
using namespace std;
map<string,int> strtonum;
//[0,12]的火星文 
string month[13]={"tret","jan","feb","mar","apr","may","jun","jly","aug","sep","oct","nov","dec"};
//13的[0,12]倍的火星文 
string name[13]={"tret","tam","hel","maa","huh","tou","kes","hei","elo","syy","lok","mer","jou"};

string numtostr[170];

void init(){
	for(int i=0;i<13;i++){
		numtostr[i]=month[i];  //个位为[1,12],十位为0
		strtonum[month[i]]=i;    //个位数的情况 
		numtostr[i*13]=name[i];    //十位数的情况 
		strtonum[name[i]]=i*13; 
	}
	for(int i=1;i<13;i++){  //十位 
		for(int j=1;j<13;j++){
			string str=name[i]+" "+month[j];  //枚举169个数,并存入字符串数组str容器中
			numtostr[i*13+j]=str;  
			strtonum[str]=i*13+j;
		} 
	}
}

int main(){
	init();
	int T;
	scanf("%d%*c",&T);
	while(T--){
		string str;
		getline(cin,str);
		if(str[0]>='0'&&str[0]<='9'){  //如果是数字 
			int num=0;
			for(int i=0;i<str.length();i++){
				num=num*10+(str[i]-'0');
			}
			cout<<numtostr[num]<<endl;
		}else{
			cout<<strtonum[str]<<endl;
		}
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_之桐_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值