邮政局选址

I - Post Office POJ - 1160

There is a straight highway with villages alongside the highway. The highway is represented as an integer axis, and the position of each village is identified with a single integer coordinate. There are no two villages in the same position. The distance between two positions is the absolute value of the difference of their integer coordinates.

Post offices will be built in some, but not necessarily all of the villages. A village and the post office in it have the same position. For building the post offices, their positions should be chosen so that the total sum of all distances between each village and its nearest post office is minimum.

You are to write a program which, given the positions of the villages and the number of post offices, computes the least possible sum of all distances between each village and its nearest post office.
Input
Your program is to read from standard input. The first line contains two integers: the first is the number of villages V, 1 <= V <= 300, and the second is the number of post offices P, 1 <= P <= 30, P <= V. The second line contains V integers in increasing order. These V integers are the positions of the villages. For each position X it holds that 1 <= X <= 10000.
Output
The first line contains one integer S, which is the sum of all distances between each village and its nearest post office.
Sample Input
10 5
1 2 3 6 7 9 11 22 44 50
Sample Output
9

原题链接

**题意:**有n个在一维平面上的村庄,给出村庄的位置,位置为升序,给出可以建立的邮局数量m,求每个村庄到离自己最近的邮局的距离之和
**题解:**定义dp[i][j]为前i个村庄建立j个邮局的最小花费,dp[i][j]=min(dp[k][j-1]+cost[k+1][i]),cost[i][j]为第i个村庄到第j个村庄建立一个邮局的最小花费,邮局建立在a[(i+j)/2]这个位置时,花费最小。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define inf 0x3f3f3f3f
int dp[350][50];
int cost[350][350];
int a[350];
int main(){
	int n,m;
	while(scanf("%d %d",&n,&m)!=EOF){
		memset(cost,0,sizeof(cost));
		memset(dp,inf,sizeof(dp));
		for(int i=1;i<=n;i++)scanf("%d",&a[i]);
		for(int i=1;i<=n;i++){
			for(int j=i;j<=n;j++){
				for(int k=i;k<=j;k++){
					cost[i][j]+=abs(a[k]-a[(i+j)/2]);
				}
			}
		}
		for(int i=1;i<=n;i++)dp[i][1]=cost[1][i];
		for(int i=2;i<=m;i++){
			for(int j=i;j<=n;j++){
				for(int k=1;k<j;k++){
					dp[j][i]=min(dp[j][i],dp[k][i-1]+cost[k+1][j]);
				}
			}
		}
		printf("%d\n",dp[n][m]);
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值