POJ 1160 Post Office :从n个村庄选m个点建邮局,使得每个村庄到邮局的距离和最小

Post Office

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 15966 Accepted: 8671

 

Description

There is a straight highway with villages alongside the highway. The highway is represented as an integer axis, and the position of each village is identified with a single integer coordinate. There are no two villages in the same position. The distance between two positions is the absolute value of the difference of their integer coordinates. 

Post offices will be built in some, but not necessarily all of the villages. A village and the post office in it have the same position. For building the post offices, their positions should be chosen so that the total sum of all distances between each village and its nearest post office is minimum. 

You are to write a program which, given the positions of the villages and the number of post offices, computes the least possible sum of all distances between each village and its nearest post office. 

Input

Your program is to read from standard input. The first line contains two integers: the first is the number of villages V, 1 <= V <= 300, and the second is the number of post offices P, 1 <= P <= 30, P <= V. The second line contains V integers in increasing order. These V integers are the positions of the villages. For each position X it holds that 1 <= X <= 10000.

Output

The first line contains one integer S, which is the sum of all distances between each village and its nearest post office.

Sample Input

10 5
1 2 3 6 7 9 11 22 44 50

Sample Output

9

 

解题思路:经典的动态规划问题(区间DP:dynamic programming)。

在v个村庄中建立p个邮局,求所有村庄到它最近的邮局的距离和,村庄在一条直线上,邮局建在村庄上。

首先求出在连续的几个村庄上建立一个邮局的最短距离(邮局的位置应该在中位数上,如果村庄个数为偶数,则处于最中间的两个村庄都可以),用数组dis[i][j]表示在第i个村庄和第j个村庄之间建一个邮局的最短距。

dis[i][j]=dis[i][j-1]+x[j]-x[(i+j)/2]; (村庄位置为x[i])

用数组dp[i][j]表示在前i个村庄中建立j个邮局的最小距离。即在前k(k<i)个村庄建立j-1个邮局,在k+1到j个村庄建立一个邮局。

dp[i][j]=min(dp[i][j],dp[k][j-1]+dis[k+1][i]) 

 

完整代码如下:

#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
#define N 305
const int inf=0x3fffffff;
int dp[N][35]; //在前i个村庄中建立j个邮局的最小耗费
int dis[N][N];//dis[i][j]:第i个村庄到第j个村庄建一个邮局的最短距离
int x[N]; //村庄位置
int main()
{
	int v,p,i,j,k;
	while(~scanf("%d%d",&v,&p))
	{
		for(i=1;i<=v;i++)
			scanf("%d",&x[i]);
		sort(x, x + i);//如果是乱序输入的话需要按照非降序排一下
		//memset(dis,0,sizeof(dis));
		for(i=1;i<=v;i++)
		{
			for(j=i+1;j<=v;j++)
			{
				dis[i][j]=dis[i][j-1]+abs(x[j]-x[(i+j)/2]);
			}
		}
		for(i=1;i<=v;i++)
		{
			dp[i][i]=0; //一个村庄一个邮局距离为零
			dp[i][1]=dis[1][i]; //前i个村庄建立一个邮局
		}
		for(j=2;j<=p;j++)
		{
			for(i=j+1;i<=v;i++)
			{
				dp[i][j]=inf;
				for(k=j-1;k<i;k++)
				{
					dp[i][j]=min(dp[i][j],dp[k][j-1]+dis[k+1][i]);
				}
			}
		}
		printf("%d\n",dp[v][p]);
	}
	return 0;
}

 

  • 3
    点赞
  • 10
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值