poj 3187 Backward Digit Sums

Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this: 

    3   1   2   4

      4   3   6

        7   9

         16
Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities. 

Write a program to help FJ play the game and keep up with the cows.

Input

Line 1: Two space-separated integers: N and the final sum.

Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input

4 16

Sample Output

3 1 2 4

Hint

Explanation of the sample: 

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.

Source



直接用c++里的 next_permutation 函数,表示产生下一个全排列  ,值得注意的是,讲数组传递到函数中计算时,原数组被传递进了函数,若要不改变原数组,用另一个数组代替,int *temp= (int *)malloc(sizeof(int)*m);  表示定义一个数组temp 这个数组的大小,根据a的大小来定。


#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
using namespace std;
int m;
int cs(int x[])
{


 int *temp= (int *)malloc(sizeof(int)*m);
      int i,j;
 for(i=0;i<m;i++)
 temp[i]=x[i];
      for(i=0;i<m-1;i++)
      {
          for(j=0;j<m-1-i;j++)
 temp[j]=temp[j]+temp[j+1];
      }
      return temp[0];
}
int main()
{
    int sum,i;
    int a[20];
    int mina[20];
    while(scanf("%d %d",&m,&sum)==2)
    {
        for(i=0;i<m;i++)
        {
            a[i]=i+1;
        }
        if(cs(a)==sum)
        {
            for(i=0;i<m-1;i++) printf("%d ",a[i]);
                printf("%d\n",a[i]);
            break;
        }
        while(next_permutation(a,a+m))
        {
           /* for(i=0;i<m-1;i++) printf("%d ",a[i]);
                printf("%d\n",a[i]);*/
             if(cs(a)==sum)
             {
                 for(i=0;i<m-1;i++) printf("%d ",a[i]);
                    printf("%d\n",a[i]);
                 break;
             }
        }
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值