hdu4497GCD and LCM+数论

Description
Given two positive integers G and L, could you tell me how many solutions of (x, y, z) there are, satisfying that gcd(x, y, z) = G and lcm(x, y, z) = L?
Note, gcd(x, y, z) means the greatest common divisor of x, y and z, while lcm(x, y, z) means the least common multiple of x, y and z.
Note 2, (1, 2, 3) and (1, 3, 2) are two different solutions.

Input
First line comes an integer T (T <= 12), telling the number of test cases.
The next T lines, each contains two positive 32-bit signed integers, G and L.
It’s guaranteed that each answer will fit in a 32-bit signed integer.

Output
For each test case, print one line with the number of solutions satisfying the conditions above.

Sample Input

2
6 72
7 33

Sample Output

72
0

lcm(x,y,z)=L=pn11pn11pn22pnnn
gcd(x,y,z)=G=pm11pm11pm22pmnn
对于L,G都存在的质因子p1而言,x,y,z中肯定有一个的指数n1,有一个的指数m1,而另外一个可以是m1-n1中的数.而3个数可以相互交换
1.当n1,n1,m1 ans=3;
2.当n1,m1,m1 ans=3;
3.当n1,z1,m1 ans=(n1-m1-1)*6;
所以综上ans=(n1-m1)*6
但是注意当n1==m1 ans=1;
最后要注意质因数分解是有可能出现两个都是质数的情况。和mi=0的情况
//数据太水。。质因数分解枚举到L也过?(分解质因数wa了几发)fu**

#include<bits/stdc++.h>
using namespace std;
#define LL long long
int factA[25],factB[25];
int tot;
void getfact(LL L,LL G){
    tot=1;
    LL N=(LL)(sqrt(L)+0.5);
    for(LL i=2;i<=N;i++){
        if(L%i==0){
            while(L%i==0){
                factA[tot]++;
                L/=i;
            }
            while(G%i==0){
                factB[tot]++;
                G/=i;
            }
            tot++;
        }
    }
    if(L>1){
        factA[tot]++;
        if(G>1)factB[tot]++;
        tot++;
    }
}

int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        LL G,L;
        scanf("%I64d %I64d",&G,&L);
        if(L%G!=0){
            printf("0\n");
            continue;
        }
        else{
            memset(factA,0,sizeof(factA));
            memset(factB,0,sizeof(factB));
            getfact(L,G);
            LL ans=1;
            for(int i=1;i<tot;i++){
                if(factA[i]>factB[i]) ans*=(factA[i]-factB[i])*6;
            }
            printf("%I64d\n",ans);
        }
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值