hdu5596GTW likes gt+倒推

Problem Description
Long long ago, there were n adorkable GT. Divided into two groups, they were playing games together, forming a column. The i−th GT would randomly get a value of ability bi. At the i−th second, the i−th GT would annihilate GTs who are in front of him, whose group differs from his, and whose value of ability is less than his.

In order to make the game more interesting, GTW, the leader of those GTs, would emit energy for m times, of which the i−th time of emitting energy is ci. After the ci second, b1,b2,…,bci would all be added 1.

GTW wanted to know how many GTs would survive after the n−th second.

Input
The first line of the input file contains an integer T(≤5), which indicates the number of test cases.

For each test case, there are n+m+1 lines in the input file.

The first line of each test case contains 2 integers n and m, which indicate the number of GTs and the number of emitting energy, respectively.(1≤n,m≤50000)

In the following n lines, the i−th line contains two integers ai and bi, which indicate the group of the i−th GT and his value of ability, respectively. (0≤ai≤1,1≤bi≤106)

In the following m lines, the i−th line contains an integer ci, which indicates the time of emitting energy for i−th time.

Output
There should be exactly T lines in the output file.

The i−th line should contain exactly an integer, which indicates the number of GTs who survive.

Sample Input

1
4 3
0 3
1 2
0 3
1 1
1
3
4

Sample Output

3
Hint
After the first seconds, b1=4,b2=2,b3=3,b4=1
After the second seconds, b1=4,b2=2,b3=3,b4=1
After the third seconds, b1=5,b2=3,b3=4,b4=1 ,and the second GT is annihilated by the third one.
After the fourth seconds, b1=6,b2=4,b3=5,b4=2
ci is unordered.
从前,有n只萌萌的GT,他们分成了两组在一起玩游戏。他们会排列成一排,第i只GT会随机得到一个能力值bi​​。在第i秒的时候,第i只GT可以消灭掉所有排在他前面的和他不是同一组的且能力值小于他的GT。
为了使游戏更加有趣,GT的首领GTW会发功m次,第ii次发功的时间为c​i​​,则在第c​i​​秒结束后, b1,b2,...,bci 都会增加1。
现在,GTW想知道在第nn秒之后,会有几只GT存活下来。

这个数与之后比它大的数的影响的。可以从后往前面扫,记最大值,如果碰到比最大值小的,去掉即可。

#include<bits/stdc++.h>
using namespace std;
#define LL long long
#define inf 0x3f3f3f3f
struct GTW {
    int team;
    int x;
}GT[55000];

int n,m,x;
int KF[55000];

int main(){
    int t;
    cin>>t;
    while(t--){
        cin>>n>>m;
        memset(KF,0,sizeof(KF));
        for(int i=1;i<=n;i++) cin>>GT[i].team>>GT[i].x;
        for(int i=1;i<=m;i++){
            cin>>x;
            KF[x]++;
        }
        int maxA=-inf,maxB=-inf;
        int ans=n;
        for(int i=n;i>=1;i--){ //枚举时间
            maxA-=KF[i];
            maxB-=KF[i];
            if(GT[i].team==0){
                if(GT[i].x<maxB) ans--;
                maxA=max(maxA,GT[i].x);
            }
            else if(GT[i].team==1){
                if(GT[i].x<maxA) ans--;
                maxB=max(maxB,GT[i].x);
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值