HDU 4864 Task(贪心)

很明显的贪心但是策略不对就会各种跪啊。

贪心的策略是先按y排再按x排然后任务在机器的前面。这里因为x的影响一定会比y大,(x不为0,x*500一定大于100)。x满足条件的情况下,sum越大对应的x就会越大。

这样从前向后扫一遍,如果是认为加入set中,是机器的话就在容器中找到一个满足条件的最大收益的一个。

Task

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1152    Accepted Submission(s): 279


Problem Description
Today the company has m tasks to complete. The ith task need xi minutes to complete. Meanwhile, this task has a difficulty level yi. The machine whose level below this task’s level yi cannot complete this task. If the company completes this task, they will get (500*xi+2*yi) dollars.
The company has n machines. Each machine has a maximum working time and a level. If the time for the task is more than the maximum working time of the machine, the machine can not complete this task. Each machine can only complete a task one day. Each task can only be completed by one machine.
The company hopes to maximize the number of the tasks which they can complete today. If there are multiple solutions, they hopes to make the money maximum.
 

Input
The input contains several test cases. 
The first line contains two integers N and M. N is the number of the machines.M is the number of tasks(1 < =N <= 100000,1<=M<=100000).
The following N lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the maximum time the machine can work.yi is the level of the machine.
The following M lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the time we need to complete the task.yi is the level of the task.
 

Output
For each test case, output two integers, the maximum number of the tasks which the company can complete today and the money they will get.
 

Sample Input
  
  
1 2 100 3 100 2 100 1
 

Sample Output
  
  
1 50004
 

Author
FZU

#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-9
///#define M 1000100
///#define LL __int64
#define LL long long
#define INF 0x7fffffff
#define PI 3.1415926535898


const int maxn = 2000100;

using namespace std;

struct node
{
    int x, y, sum;
    int flag;
} f[maxn];

bool cmp(node a, node b)
{
    if(a.y == b.y)
    {
        if(a.x == b.x)
            return a.flag<b.flag;
        return a.x < b.x;
    }
    return a.y < b.y;
}

multiset<int> st;
multiset<int>::iterator it;

int Del(int x)
{
    if(st.size() == 0)return 0;
    it = st.begin();
    if(x < (*it)) return 0;
    it = st.lower_bound(x);
    if(it == st.end())
    {
        it--;
        int p = (*it);
        st.erase(it);
        return p;
    }
    if((*it) == x)
    {
        st.erase(it);
        return x;
    }
    it--;
    int p = (*it);
    st.erase(it);
    return p;
}

int main()
{
    int n, m;
    while(~scanf("%d %d",&n, &m))
    {
        for(int i = 1; i <= n; i++)
        {
            scanf("%d %d",&f[i].x, &f[i].y);
            f[i].sum = 500*f[i].x+2*f[i].y;
            f[i].flag = 1;
        }
        for(int i = n+1; i <= n+m; i++)
        {
            scanf("%d %d",&f[i].x, &f[i].y);
            f[i].sum = 500*f[i].x+2*f[i].y;
            f[i].flag = 0;
        }
        sort(f+1, f+n+m+1, cmp);
        int cnt = 0;
        LL ans = 0;
        st.clear();
        for(int i = 1; i <= n+m; i++)
        {
            if(!f[i].flag)
            {
                st.insert(f[i].sum);
                continue;
            }
            int tmp = Del(f[i].sum);
            if(tmp)
            {
                cnt++;
                ans += (LL)tmp;
            }
        }
        cout<<cnt<<" "<<ans<<endl;
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值