HDU5162Jump and Jump...

Jump and Jump...

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1355    Accepted Submission(s): 687


Problem Description
There are  n  kids and they want to know who can jump the farthest. For each kid, he can jump three times and the distance he jumps is maximum distance amount all the three jump. For example, if the distance of each jump is (10, 30, 20), then the farthest distance he can jump is 30. Given the distance for each jump of the kids, you should find the rank of each kid.
 

Input
There are multiple test cases. The first line of input contains an integer  T (1T100) , indicating the number of test cases. For each test case: The first line contains an integer  n (2n3) , indicating the number of kids. For the next  n  lines, each line contains three integers  ai,bi  and  ci  ( 1ai,bi,ci,300 ), indicating the distance for each jump of the  i -th kid. It's guaranteed that the final rank of each kid won't be the same (ie. the farthest distance each kid can jump won't be the same).
 

Output
For each test case, you should output a single line contain  n  integers, separated by one space. The  i -th integer indicating the rank of  i -th kid.
 

Sample Input
  
  
2 3 10 10 10 10 20 30 10 10 20 2 3 4 1 1 2 1
 

Sample Output
  
  
3 1 2 1 2
Hint
For the first case, the farthest distance each kid can jump is 10, 30 and 20. So the rank is 3, 1, 2.
 

这是BEST CODE里面的题目,题意就不讲了恩,不懂题意的直接看看中文版的;
http://bestcoder.hdu.edu.cn/contests/contest_chineseproblem.php?cid=563&pid=1001

题目比较简单直接给出代码:
/*
	对数据分析,最多只有三个孩子,最少有两个孩子;分情况考虑就好了,当n等于2的时候和当n等于3的时候,复制粘连
就好了;
	每一个孩子只跳三次,那么我们只要对每一个孩子进行下排序就好了,这里我用的是降序排序,就得到a[0] b[0] c[0],
分别是三个孩子的跳远的最大值;
然后对这几个最大值进行排序,最后控制下输出格式就好了;
*/
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;
bool Cmp(const int &a,const int &b)//降序排序;
{
	return a > b;
}
int main()
{
	int T,x,y,z,d[3];
	cin >> T;
	int n;
	int a[3], b[3], c[3];
	while (T--)
	{
		cin >> n;
		for (int i = 0; i < 3; i++)
			cin >> a[i];
		for (int i = 0; i < 3; i++)
			cin >> b[i];
		sort(a, a + 3, Cmp);
		sort(b, b + 3, Cmp);
		if (n == 3)
		{
			for (int i = 0; i < 3; i++)
				cin >> c[i];
			sort(c, c + 3, Cmp);
			z = c[0];
		}
		if (n == 3)
		{
			d[0] = a[0]; d[1] = b[0]; d[2] = c[0];
			sort(d, d + 3, Cmp);
			for (int i = 0; i < 3; i++)
			{
				if (a[0] == d[i])cout << i+1;
			}
			for (int i = 0; i < 3; i++)
			{
				if (b[0] == d[i])cout <<" "<<i+1;
			}
			for (int i = 0; i < 3; i++)
			{
				if (c[0] == d[i])cout << " " << i+1 << endl;;
			}
		}
		else
		{
			d[0] = a[0]; d[1] = b[0];
			sort(d, d + 2, Cmp);
			for (int i = 0; i < 3; i++)
			{
				if (a[0] == d[i])cout << i + 1;
			}
			for (int i = 0; i < 3; i++)
			{
				if (b[0] == d[i])cout << " " << i + 1<<endl;
			}
		}
	}
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值