HDU1040As Easy As A+B

As Easy As A+B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 50426    Accepted Submission(s): 21561


Problem Description
These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!
 

Input
Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line. 
It is guarantied that all integers are in the range of 32-int.
 

Output
For each case, print the sorting result, and one line one case.
 

Sample Input
  
  
2 3 2 1 3 9 1 4 7 2 5 8 3 6 9
 

Sample Output
  
  
1 2 3 1 2 3 4 5 6 7 8 9
 
终于放假了,考完试回家忍不住又来做几个题目,先来几个开胃菜:
正如题目所说 比A+B 还简单的问题;
题目其实是一个比较简单的排序问题,要求将已给出的数字按升序排序排出来;排序的话我们可以直接调用C++的算法的头文件 #include<algorithm>这里面有一个sort排序函数; 
sort(数组名,  数组的长度,   Cmp);  Cmp()其实是自己自定义的排序函数,如果我们只是默认用sort(num,num+n);去进行排序的话,那么就会是默认的升序排序;不懂的话可以百度下sort()函数的原型;
不过有些同学又会说了,没有学过C++怎么办;可以试试 qsort();在头文件#include<stdlib.h>中;
实在不想用这些怎么办,可以自己写个排序函数恩,快排,归并,冒泡,选择,都是可以的;刚入门的同学想要了解的话可以加我博客关注,最近这段时间我打算把一系列的排序更新到博客上;喜欢的朋友可以请加关注,也可以分享给好友;

本题AC代码:
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
	int t, n;
	int num[10000];
	cin >> t;
	while (t--)
	{
		cin >> n;
		for (int i = 0; i < n; i++)
			cin >> num[i];
		sort(num, num + n);
		for (int i = 0; i < n; i++)
		{
			if (i == 0)cout << num[i];
			else cout << " " << num[i];
		}
		cout << endl;
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值