优先队列priority queue

优先队列是分优先级的队列
题目
The only printer in the computer science students’ union is experiencing an extremely heavy workload. Sometimes there are a hundred jobs in the printer queue and you may have to wait for hours to get a single page of output.
Because some jobs are more important than others, the Hacker General has invented and implemented a simple priority system for the print job queue. Now, each job is assigned a priority between 1 and 9 (with 9 being the highest priority, and 1 being the lowest), and the printer operates as follows.
The first job J in queue is taken from the queue.
If there is some job in the queue with a higher priority than job J, then move J to the end of the queue without printing it.
Otherwise, print job J (and do not put it back in the queue).
In this way, all those important muffin recipes that the Hacker General is printing get printed very quickly. Of course, those annoying term papers that others are printing may have to wait for quite some time to get printed, but that’s life.
Your problem with the new policy is that it has become quite tricky to determine when your print job will actually be completed. You decide to write a program to figure this out. The program will be given the current queue (as a list of priorities) as well as the position of your job in the queue, and must then calculate how long it will take until your job is printed, assuming that no additional jobs will be added to the queue. To simplify matters, we assume that printing a job always takes exactly one minute, and that adding and removing jobs from the queue is instantaneous.

Input Format

One line with a positive integer: the number of test cases (at most 20). Then for each test case:

One line with two integers n and m, where n is the number of jobs in the queue (1 ≤ n ≤ 50) and m is the position of your job (0 ≤ m ≤ n −1). The first position in the queue is number 0, the second is number 1, and so on.
One linewith n integers in the range 1 to 9, giving the priorities of the jobs in the queue. The first integer gives the priority of the first job, the second integer the priority of the second job, and so on.
Output Format

For each test case, print one line with a single integer; the number of minutes until your job is completely printed, assuming that no additional print jobs will arrive.

Input Sample

3
1 0
5
4 2
1 2 3 4
6 0
1 1 9 1 1 1
Output Sample

1
2
5
题目大致意思是:给出一些工作然后按照优先级排列,然后推算指定位置工作完成的时间。

#include<iostream>
#include<queue>
using namespace std;
int main() {
    int n;
    cin >> n;
    while (n--) {
        int num, m;
        cin >> num >> n;
        priority_queue<int> pqueue;
        queue<int> cque;
        queue<int> ique;
        for (int i = 0; i < num; i++) {
            int temp;
            cin >> temp;
            pqueue.push(temp);
            ique.push(temp);
            cque.push(i);
        }
        int count = 0;
        while (1) {
            while (ique.front() != pqueue.top()) {
                int t = ique.front();
                ique.pop();
                ique.push(t);
                t = cque.front();
                cque.pop();
                cque.push(t);
            }
            count++;
            if (cque.front() == m) {
                cout << count << endl;
                break;
            } else {
                pqueue.pop();
                ique.pop();
                cque.pop();
            }
        }
    }
    return 0;
}

不用优先队列的做法

#include<iostream>
#include<vector>
using namespace std;
struct node {
    int index;
    int pri;
    node(int i; int p): index(i), pri(p) {}
};
int mian() {
     int n;
     cin >> n;
     while (n--) {
         int allJobs, myJob;
         cin >> allJobs >> myJob;
         vector<int> que;
         for (int i = 0; i < allJobs; i++) {
             int temp;
             cin >> temp;
             que.push_back(node(i, temp));
         }
         int sum = 0;
         while (!empty()) {
             node top = que.front();
             int len = que.size();
             bool f = false;
             for (int i = 1; i < len; i++) {
                 if (que[i].pri > que[0].pri) {
                     que.back_push(top);
                     f = true;
                     break;
                 }
             }
             que.erase(que.begin());
             if (!f) 
                 sum++;
             if (!f && top.index == myJob)
                 break;
         }
         cout << sum << endl;
     }
 }
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值