POJ 2031 ZOJ 1718 Building a Space Station



You are a member of the space station engineering team, and are assigned a task in the construction process of the station. You are expected to write a computer program to complete the task.  The space station is made up with a number of units, called cells. All cells are sphere-shaped, but their sizes are not necessarily uniform. Each cell is fixed at its predetermined position shortly after the station is successfully put into its orbit. It is quite strange that two cells may be touching each other, or even may be overlapping. In an extreme case, a cell may be totally enclosing another one. I do not know how such arrangements are possible.  All the cells must be connected, since crew members should be able to walk from any cell to any other cell. They can walk from a cell A to another cell B, if, (1) A and B are touching each other or overlapping, (2) A and B are connected by a `corridor', or (3) there is a cell C such that walking from A to C, and also from B to C are both possible. Note that the condition (3) should be interpreted transitively.  You are expected to design a configuration, namely, which pairs of cells are to be connected with corridors. There is some freedom in the corridor configuration. For example, if there are three cells A, B and C, not touching nor overlapping each other, at least three plans are possible in order to connect all three cells. The first is to build corridors A-B and A-C, the second B-C and B-A, the third C-A and C-B. The cost of building a corridor is proportional to its length. Therefore, you should choose a plan with the shortest total length of the corridors.  You can ignore the width of a corridor. A corridor is built between points on two cells' surfaces. It can be made arbitrarily long, but of course the shortest one is chosen. Even if two corridors A-B and C-D intersect in space, they are not considered to form a connection path between (for example) A and C. In other words, you may consider that two corridors never intersect. 
Input
The input consists of multiple data sets. Each data set is given in the following format.  n  x1 y1 z1 r1  x2 y2 z2 r2  ...  xn yn zn rn  The first line of a data set contains an integer n, which is the number of cells. n is positive, and does not exceed 100.  The following n lines are descriptions of cells. Four values in a line are x-, y- and z-coordinates of the center, and radius (called r in the rest of the problem) of the sphere, in this order. Each value is given by a decimal fraction, with 3 digits after the decimal point. Values are separated by a space character.  Each of x, y, z and r is positive and is less than 100.0.  The end of the input is indicated by a line containing a zero. 
Output
For each data set, the shortest total length of the corridors should be printed, each in a separate line. The printed values should have 3 digits after the decimal point. They may not have an error greater than 0.001.  Note that if no corridors are necessary, that is, if all the cells are connected without corridors, the shortest total length of the corridors is 0.000. 
Sample Input
3
10.000 10.000 50.000 10.000
40.000 10.000 50.000 10.000
40.000 40.000 50.000 10.000
2
30.000 30.000 30.000 20.000
40.000 40.000 40.000 20.000
5
5.729 15.143 3.996 25.837
6.013 14.372 4.818 10.671
80.115 63.292 84.477 15.120
64.095 80.924 70.029 14.881
39.472 85.116 71.369 5.553
0
Sample Output
20.000
0.000
73.834

题意:

建立空间站,空间站为球型,球与球有相接,内含,相离,三种情况。求把各个空间站连接起来的路径的最小值。相接和内含的情况可看成距离为零。

题解:

求最小生成树问题。可用Kruskal算法与Prim算法。

Kruskal算法中,对权值大小进行排序的方法,可用sort排序;

求出各个球之间的距离,定义结构体存储点与点,以及点与点之间的距离。进行排序。当然,在求最短路径时需用并查集判断当前路径是否有必要加到路径里,注意截止条件与精度问题。

Prim算法:也是求各个球之间的距离,从第一个点开始连接与之最近的点,依次进行。注意截止条件与精度问题。

最好用double型存储各个坐标与半径,对于误差0.001,几乎可以忽视。

Kruskal算法代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;

double mp[110][110];
int f[110];

struct node
{
    double x,y,z,r,s;
    int a,b;
} q[11000];

double cmp(node T1,node T2)
{
    return T1.s<T2.s;
}

double fun(int ff,int g)
{

    double t1=(q[ff].x-q[g].x)*(q[ff].x-q[g].x);
    double t2=(q[ff].y-q[g].y)*(q[ff].y-q[g].y);
    double t3=(q[ff].z-q[g].z)*(q[ff].z-q[g].z);
    double T=sqrt(t1+t2+t3)-q[ff].r-q[g].r;
    if(T <= 0.001)
        return 0;
    else
        return T;

}

int getf(int x)
{
    if(f[x]==x)
        return x;
    else
    {
        f[x]=getf(f[x]);
        return f[x];
    }
}

int merg(int x,int y)
{
    int t1=getf(x);
    int t2=getf(y);
    if(t1!=t2)
    {
        f[t2]=t1;
        return 1;
    }
    return 0;
}

int main()
{
    int n;
    while(~scanf("%d",&n) && n)
    {
        int i,j,u=0;
        memset(q,0,sizeof(q));
        for(i=0; i<n; i++)
        {
            scanf("%lf%lf%lf%lf",&q[i].x,&q[i].y,&q[i].z,&q[i].r);
        }
        for(i=0; i<n; i++)
        {
            for(j=0; j<n; j++)
            {
                q[u].a=i;
                q[u].b=j;
                q[u].s=fun(i,j);
                u++;
            }
        }
        sort(q,q+u,cmp);
        for(i=0; i<n; i++)
            f[i]=i;
        double sum=0;
        int num=0;
        for(i=0; i<u; i++)
        {
            if(merg(q[i].a,q[i].b))
            {
                sum+=q[i].s;
                num++;
            }
            if(num==n-1)
                break;
        }
        printf("%.3f\n",sum);
    }
    return 0;
}

Prim算法代码如下:

这段源代码非本人编写。

#include<stdio.h>
#include<string.h>
#include<math.h>
#define INF 0x3f3f3f3f


double mp[110][110], dis[110], sum;
int book[110], n;


struct node
{
    double x;
    double y;
    double z;
    double r;
} Q[110];


double pan( double x1, double y1, double z1, double r1, double x2, double y2, double z2, double r2 )
{
    double tx = (x1-x2) * (x1-x2);
    double ty = (y1-y2) * (y1-y2);
    double tz = (z1-z2) * (z1-z2);
    double td = sqrt(tx+ty+tz)-r1-r2;
    if( td <= 0.0)
        return 0;
    else
        return td;
}


void Prim( int v )
{
    for( int i = 1; i <= n; i++ )
        dis[i] = mp[v][i];
    book[v] = 1;
    for( int i = 0; i < n; i++ )
    {
        double minn = INF;
        int vv = v;
        for( int k = 1; k <= n; k++ )
        {
            if( !book[k] && dis[k] < minn )
            {
                minn = dis[k];
                vv = k;
            }
        }
        book[vv] = 1;
        sum += dis[vv];
        for( int k = 1; k <= n; k++ )
        {
            if( !book[k] && dis[k] > mp[vv][k] )
                dis[k] = mp[vv][k];
        }
    }
}


int main()
{
    while( scanf("%d",&n) && n )
    {
        for( int i = 1; i <= n; i++ )
            scanf("%lf%lf%lf%lf",&Q[i].x,&Q[i].y,&Q[i].z,&Q[i].r);
        for( int i = 1; i <= n; i++ )
        {
            for( int j = 1; j <= n; j++ )
            {
                if( i == j )
                    mp[i][j] = 0;
                else
                    mp[i][j] = pan(Q[i].x,Q[i].y,Q[i].z,Q[i].r,Q[j].x,Q[j].y,Q[j].z,Q[j].r);
            }
        }
        sum = 0;
        memset(book,0,sizeof(book));
        Prim(1);
        printf("%.3lf\n",sum);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值