POJ - 1426 Find The Multiple(广搜)

题目链接:http://poj.org/problem?id=1426点击打开链接

Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 33048 Accepted: 13830 Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

Source


题意迷人

讲的是给你一个数 你要找一个十进制的数 只能由0和1组成

然后这个十进制的数要能整除这个给的数

分析过程:

1.先创立一个数为1 (因为第一个数不为0)将他入队

2.每次从队中取出首元素进行判断 然后就是*10与(*10+1)的两个方向的广搜

3.然后计算 当前这个数两个方向的值 与给出数的余数 如果不为0 就看这个余数是否被标记过 如果标记过就跳过 没有就标记 然后入队 重复2 直到队列为空或发现余数为0

这样的标记化需要注意要记录每个操作 用vector的赋值可以快速完成 

这里将1记为*10

将2记为+1;(因此(*10+1)1和2的操作都有记录)

最后根据记录的操作次数进行计算即可

此时应该也是保证所计算的数为最小的

#include <iostream>
#include <queue>
#include <stdio.h>
#include <stdlib.h>
#include <stack>
#include <limits.h>
#include <string>
#include <string.h>
#include <vector>
#include <set>
#include <map>
#include <algorithm>
#include <math.h>
using namespace std;
int main()
{
    int n=0;
    while(~scanf("%d",&n)&&n)
    {
        int book[n+n];
        for(int i=0;i<=n+n;i++)
            book[i]=0;
        vector<int > s[n+1];
        vector<int > ss;
        int mid=1;
        queue <int > q;
        while(!q.empty())
            q.pop();
        for(int i=0;i<n+1;i++)
        s[i].clear();
        ss.clear();
        q.push(1);
        while(!q.empty())
        {
            int mid=q.front();
                q.pop();
            ss=s[mid];
            if(mid==0)
            {
                break;
            }
            if(!book[mid*10%n])
            {
                book[mid*10%n]=1;
                s[mid*10%n]=ss;
                s[mid*10%n].push_back(1);
                q.push(mid*10%n);
            }
            if(!book[(mid*10+1)%n])
            {
                book[(mid*10+1)%n]=1;
                s[(mid*10+1)%n]=ss;
                s[(mid*10+1)%n].push_back(1);
                s[(mid*10+1)%n].push_back(2);
                q.push((mid*10+1)%n);
            }
        }
        long long int ans=1;
        for(int i=0;i<ss.size();i++)
        {
            if(ss[i]==1)
                ans*=10;
            else
                ans+=1;
        }
        cout << ans<< endl;
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值