POJ-1426 Find The Multiple

Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 31553 Accepted: 13158 Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

Source

一道不是数水坑也不是走迷宫的DFS,题意:给一个数,让你找到一个数字对所给数取模,结果为0,但是这个数只能由数字0和1构成答案也许不唯一,输出一个结果即可。

思路:既然寻找数只能由0,1构成,那么1,10,11,100,110这样的数字满足第一个条件,设a=1,那么满足条件的数可以表示为a*10和a*10+1,递归就可以把a越滚越大且只由0,1构成,对每个构造出来的数取模检查,如果结果为0,输出结果,退出函数。由于数字可能会很大且为整数,所以使用unsigned long long类型定义变量。step是为了限制递归深度,超过20之后速度会很慢,但貌似这里在递归到19层之前就能找到结果。

#include<iostream>
#define ull unsigned long long
using namespace std;
int n;
int flag=0;
void dfs(ull a,int step)
{
    if(flag || step==19)
        return ;
    if(a%n==0)
    {
        cout << a << endl;
        flag=1;
        return ;
    }
    else
    {
       dfs(a*10,step+1);
       dfs(a*10+1,step+1);
    }
}
int main()
{
    while(cin >> n && n)
    {
        flag=0;
        dfs(1,0);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值