HDU - 1394 Minimum Inversion Number(线段树求逆序)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1394点击打开链接

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22247    Accepted Submission(s): 13239


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 
当一个数从头到尾时 逆序数增加n-1-a[i]个 减少a[i]个

对数值进行线段树处理

#include <bits/stdc++.h>
using namespace std;
#define maxn 22222
struct xjy
{
	int left;
	int right;
	int num;
}tree[maxn<<2];
int a[maxn];
int ans;
void build(int root,int left,int right)
{
	tree[root].left=left;
	tree[root].right=right;
	tree[root].num=0;
	if(left==right)
		return;
	int mid=(left+right)>>1;
	build(root<<1,left,mid);
	build(root<<1|1,mid+1,right);
}
void update(int root,int left,int right)
{
	if(tree[root].left==left&&tree[root].right==right)
	{
		tree[root].num++;
		return;
	}
	int mid=(tree[root].left+tree[root].right)>>1;
	if(right<=mid)
		update(root<<1,left,right);
	else if(left>mid)
		update(root<<1|1,left,right);
	else
	{
		update(root<<1,left,mid);
		update(root<<1|1,mid+1,right);
	}
	tree[root].num=tree[root<<1].num+tree[root<<1|1].num;
}
void query(int root,int left,int right)
{
	if(tree[root].left==left&&tree[root].right==right)
	{
		ans+=tree[root].num;
		return;
	}
	int mid=(tree[root].left+tree[root].right)>>1;
	if(right<=mid)
		query(root<<1,left,right);
	else if(left>mid)
		query(root<<1|1,left,right);
	else 
	{
		query(root<<1,left,mid);
		query(root<<1|1,mid+1,right);
	}
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		ans=0;
		build(1,0,n);
		for(int i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
			query(1,a[i]+1,n);
			update(1,a[i],a[i]);
		}
		int minn=ans;
		for(int i=0;i<n;i++)
		{
			ans=ans-a[i]+n-1-a[i];
			minn=min(minn,ans);
		}
		printf("%d\n",minn);
	}

}











  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值