HDU - 1238 Substrings (kmp)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1238点击打开链接

Substrings

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11429    Accepted Submission(s): 5489


Problem Description
You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.
 

Input
The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string. 
 

Output
There should be one line per test case containing the length of the largest string found.
 

Sample Input
 
 
2 3 ABCD BCDFF BRCD 2 rose orchid
 

Sample Output
 
 
2 2
 


求最长的正序或逆序出现在所有字符串中的子串长度

kmp+暴力枚举

#include <string>
#include <iostream>
#include <stdio.h>
#include <vector>
#include <string.h>
#include <algorithm>
using namespace std;
int nnext[111];
char ss[111][111];
char mmid[111];
void getnext()
{
	int i=0;
	int j=-1;
	nnext[0]=-1;
	int len=strlen(mmid);
	while(i<len)
	{
		if(j==-1||mmid[i]==mmid[j])
		{
			i++;
			j++;
			nnext[i]=j;
		}
		else
			j=nnext[j];
	}
}
int kmp(int s)
{
	int i=0;int j=0;
	int len=strlen(ss[s]);
	int lenn=strlen(mmid);
	getnext();
	while(i<len)
	{
		if(j==-1||ss[s][i]==mmid[j])
		{
			i++;
			j++;
		}
		else
			j=nnext[j];
		if(j==lenn)
			return 1;
	}
	return 0;
}
int  main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		char ans[111]="";
		int n;
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			scanf(" %s",ss[i]);
		}
		int len=strlen(ss[0]);
		for(int i=0;i<len;i++)
			for(int j=i;j<len;j++)
		{
			mmid[0]='\0';
			int cnt=0;
			for(int k=i;k<=j;k++)
				mmid[cnt++]=ss[0][k];
			mmid[cnt]='\0';
			if(strlen(ans)>strlen(mmid))
				continue;
			int flag=1;
			//printf("%s\n",mmid);
			//getchar();
			int flag1=1;
			for(int k=1;k<n;k++)
			{
				flag1&=kmp(k);
				//printf("%s\n",mmid);
			}
			char midd[111];
			for(int i=0;i<cnt;i++)
				{
					midd[i]=mmid[i];
				}
			for(int i=0;i<cnt;i++)
			{
				mmid[i]=midd[cnt-i-1];
			}
			int flag2=1;
			for(int k=1;k<n;k++)
			{
				flag2&=kmp(k);
				//printf("%s\n",mmid);
			}
			flag&=(flag1||flag2);
			if(flag)
			{

				if(strlen(ans)<strlen(mmid))
					{
						for(int ii=0;ii<strlen(mmid);ii++)
						{
							ans[ii]=mmid[ii];
						}
					}
				else if(strlen(ans)==strlen(mmid))
				{
					if(strcmp(ans,mmid)>=1)
					{
						for(int ii=0;ii<strlen(mmid);ii++)
						{
							ans[ii]=mmid[ii];
						}
					}
				}
			}
		}
		printf("%d\n",strlen(ans));
	}
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值