这里有 n 列火车将要进站再出站,但是,每列火车只有 1 节,那就是车头。
这 n 列火车按 1 到 n 的顺序从东方左转进站,这个车站是南北方向的,它虽然无限长,只可惜是一个死胡同,而且站台只有一条股道,火车只能倒着从西方出去,而且每列火车必须进站,先进后出。
也就是说这个火车站其实就相当于一个栈,每次可以让右侧头火车进栈,或者让栈顶火车出站。
车站示意如图:
出站<—— <——进站
|车|
|站|
|__|
现在请你按《字典序》输出前 20 种可能的出栈方案。
输入格式
输入一个整数 n,代表火车数量。
输出格式
按照《字典序》输出前 20 种答案,每行一种,不要空格。
数据范围
1≤n≤20
输入样例:
3
输出样例:
123
132
213
231
321
#include <iostream>
#include <stack>
#include <vector>
using namespace std;
int n;//输入
int count = 20;
int state1 = 1;//作为尚未入栈的火车序列
stack<int> state2;//作为车站的栈,保存现在在栈内的火车序列
vector<int> state3;//作为已经出栈的火车序列,最后由于输出的结果
void bfs(){
if(!count) return ;
if(state3.size() == n){
for(auto x : state3){
cout << x ;
}
cout << endl;
count--;
return;
}
if(state2.size()){
state3.push_back(state2.top());
state2.pop();
bfs();
state2.push(state3.back());
state3.pop_back();//这两步处理意在返回先前的情况
}
if(state1 <= n){
state2.push(state1);
state1++;
bfs();
state1--;
state2.pop();//这两步处理意在返回先前的情况
}
}
int main(){
cin >> n;
bfs();
return 0;
}