Maximum sum(双向dp)

Maximum sum
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 38077 Accepted: 11902

Description

Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:
Your task is to calculate d(A).

Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input. 
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.

Output

Print exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13

AC代码:

#include <iostream>
#include<cmath>
using namespace std;
#define inf 0xfffffff
int dp[50010],dp1[50010],a[50010],sm[50010];
int main(){
	int t,n,i;
	int sum,temp;
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		for(i=1;i<=n;i++)
		scanf("%d",&a[i]);
		temp=inf;
		dp[1]=a[1];
		dp1[n]=a[n];
		for(i=2;i<=n;i++)
		dp[i]=max(a[i],dp[i-1]+a[i]);		
		for(i=n-1;i>=1;i--)
		dp1[i]=max(a[i],dp1[i+1]+a[i]);
		sm[n]=dp1[n];
		for(i=n-1;i>=1;i--)
		sm[i]=max(sm[i+1],dp1[i]);
		sum=-inf;
		for(i=2;i<=n;i++)
		sum=max(sum,dp[i-1]+sm[i]);
		printf("%d\n",sum);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值