二叉树--由前序遍历和中序遍历建树


  • 题目

    8:Tree Recovery

    总Time Limit: 1000ms Memory Limit: 65536kB
    Description
    Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.
    This is an example of one of her creations:

    D
    / \
    / \
    B E
    / \ \
    / \ \
    A C G
    /
    /
    F
    To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.
    She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

    Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
    However, doing the reconstruction by hand, soon turned out to be tedious.
    So now she asks you to write a program that does the job for her!

    Input
    The input will contain one or more test cases.
    Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)
    Input is terminated by end of file.

    Output
    For each test case, recover Valentine’s binary tree and print one line containing the tree’s postorder traversal (left subtree, right subtree, root).
    Sample Input
    DBACEGF ABCDEFG
    BCAD CBAD
    Sample Output
    ACBFGED
    CDAB
    Source
    Ulm Local 1997


  • 分析:前序的第一个元素是根元素,由此可以在中序中找到左子树和右子树的分解处,然后递归建树即可。
/*
@Filename:      code.cpp
@Author:        wyl6 
@Mail:          ustbcs_wyl@163.com
@Thought:
*/
#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <stack>
#include <queue>
#include <algorithm>
#include <cstring>
#include <string>
#include <cmath>
#include <vector>
#include <bitset>
#include <list>
#include <sstream>
#include <set>
#include <functional>
using namespace std;

const int maxn = 100;
char preOrder[maxn],inOrder[maxn];
struct node
{
    char v;
    node *l,*r;
    node():v('0'),l(NULL),r(NULL){}
};

node* BuildTree(int preB,int preE,int inB,int inE)
{
    node *root = new node();
    root->v = preOrder[preB];
    int i = 0;
    while(inOrder[inB+i] != root->v) i++;
    if(i>0)//如果左子树存在
        root->l = BuildTree(preB+1,preB+i,inB,inB+i-1);
    if(inB+i<inE)//如果右子树存在
        root->r = BuildTree(preB+i+1,preE,inB+i+1,inE);
    return root;
}

void PostOrder(node *root)
{
    if(root == NULL) return;
    PostOrder(root->l);
    PostOrder(root->r);
    cout << root->v;
}

void DelTree(node *root)
{
    if(root == NULL) return;
    DelTree(root->l);
    DelTree(root->r);
    delete root;
}

int main()
{
    while(cin >> preOrder >> inOrder) {
        int len = strlen(preOrder);
        node *tmpRoot = BuildTree(0,len-1,0,len-1);
        PostOrder(tmpRoot);
        DelTree(tmpRoot);
        cout << endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值