String painter
Time Limit: 5000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 4000 Accepted Submission(s): 1866
Problem Description
There are two strings A and B with equal length. Both strings are made up of lower case letters. Now you have a powerful string painter. With the help of the painter, you can change a segment of characters of a string to any other character you want. That is, after using the painter, the segment is made up of only one kind of character. Now your task is to change A to B using string painter. What’s the minimum number of operations?
Input
Input contains multiple cases. Each case consists of two lines:
The first line contains string A.
The second line contains string B.
The length of both strings will not be greater than 100.
The first line contains string A.
The second line contains string B.
The length of both strings will not be greater than 100.
Output
A single line contains one integer representing the answer.
Sample Input
zzzzzfzzzzz abcdefedcba abababababab cdcdcdcdcdcd
Sample Output
6 7
Source
Recommend
港真一开始看不出是区间DP,胡搞了半天都不行就去看别人的题解了...发觉是道非常好的区间DP题,值得好好研究与理解,对解决其他的区间DP题有很好的效果。自己的代码太丑了也没注释,大概找了一位大神的代码加注释,思想是一样的。
#include <bits/stdc++.h>
using namespace std;
char s1[105],s2[105];
int dp[105][105];//dp[i][j]为i~j的刷法
int ans[105],i,j,k,len;
int main()
{
while(~scanf("%s%s",s1,s2))
{
len = strlen(s1);
memset(dp,0,sizeof(dp));
for(j = 0; j<len; j++)
{
for(i = j; i>=0; i--)//j为尾,i为头
{
dp[i][j] = dp[i+1][j]+1;//先每个单独刷
for(k = i+1; k<=j; k++)//i到j中间所有的刷法
{
if(s2[i]==s2[k])
dp[i][j] = min(dp[i][j],(dp[i+1][k]+dp[k+1][j]));//i与k相同,寻找i刷到k的最优方案
}
}
}
for(i = 0; i<len; i++)
ans[i] = dp[0][i];//根据ans的定义先初始化
for(i = 0; i<len; i++)
{
if(s1[i] == s2[i])
ans[i] = ans[i-1];//如果对应位置相等,这个位置可以不刷
else
{
for(j = 0; j<i; j++)
ans[i] = min(ans[i],ans[j]+dp[j+1][i]);//寻找j来分割区间得到最优解
}
}
printf("%d\n",ans[len-1]);
}
return 0;
}