hdu5319 Painter(模拟题)

99 篇文章 2 订阅

C - Painter

  HDU - 5319 

Mr. Hdu is an painter, as we all know, painters need ideas to innovate , one day, he got stuck in rut and the ideas dry up, he took out a drawing board and began to draw casually. Imagine the board is a rectangle, consists of several square grids. He drew diagonally, so there are two kinds of draws, one is like ‘\’ , the other is like ‘/’. In each draw he choose arbitrary number of grids to draw. He always drew the first kind in red color, and drew the other kind in blue color, when a grid is drew by both red and blue, it becomes green. A grid will never be drew by the same color more than one time. Now give you the ultimate state of the board, can you calculate the minimum time of draws to reach this state.
InputThe first line is an integer T describe the number of test cases. 
Each test case begins with an integer number n describe the number of rows of the drawing board. 
Then n lines of string consist of ‘R’ ‘B’ ‘G’ and ‘.’ of the same length. ‘.’ means the grid has not been drawn. 
1<=n<=50 
The number of column of the rectangle is also less than 50. 
Output 
Output an integer as described in the problem description. 
OutputOutput an integer as described in the problem description.Sample Input
2
4
RR.B
.RG.
.BRR
B..R
4
RRBB
RGGB
BGGR
BBRR
Sample Output
3
6


  只能斜着画,如果某个位置是R 如果其左上角是R或者G 证明不用再多划一笔 如果是B 其右上角如果是B或者G 那也不用再多画一次 如果是G 那其左上角如果是R或者G 右上角如果是B或者G 就都不用多画一次了  大概照着这个思维打了一下 一直wa 后来发现是因为输入的N并不是代表N*N的矩阵 坑啊。。。。是输入N行 每行长度自定。。好吧没好好审题 改了之后就AC了。


#include<iostream>
#include<string.h>
#include<cstdio>
using namespace std;
char mp[100][100];
int main() {
	int t,n;
	cin>>t;
	while(t--) {
		cin>>n;
		memset(mp,0,sizeof(mp));
		for(int i=1; i<=n; i++)
			scanf("%s",mp[i]+1);
		
		int m=strlen(mp[1]+1);
		int ans=0;
		for(int i=1; i<=n; i++)
			for(int j=1; j<=m; j++) {
				if(mp[i][j]=='R')
					if(!(mp[i-1][j-1]=='R'||mp[i-1][j-1]=='G')) ans++;

			}
			
		for(int i=1; i<=n; i++)
			for(int j=1; j<=m; j++) {
				if(mp[i][j]=='B')
						if(!(mp[i-1][j+1]=='B'||mp[i-1][j+1]=='G')) ans++;

			}
			
		for(int i=1; i<=n; i++)
			for(int j=1; j<=m; j++) {
				if(mp[i][j]=='G')
					if(!(mp[i-1][j-1]=='R'||mp[i-1][j-1]=='G')) ans++;

			}	
			
			for(int i=1; i<=n; i++)
			for(int j=1; j<=m; j++) {
				if(mp[i][j]=='G')
						if(!(mp[i-1][j+1]=='B'||mp[i-1][j+1]=='G')) ans++;

			}	
	    
		cout<<ans<<endl;
	}
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值