poj 2001 Shortest Prefixes

Shortest Prefixes
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 11944 Accepted: 5088

Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents. 

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo". 

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car". 

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car carcarbonate carbona
这是一个联系字典树的好机会,虽然不难不过也有一些小技巧哦
//Shortest Prefixes
//这道题的目的是求出每个单词的前缀,这个前缀不被给出的其他任何单词所共有
//这道题的目的就是建立一个tria树,将所有的单词插入到树中,
//用该从叶节点向上遍历,如果一条路径上每个节的下一个节点遇到了第一个分支,这个节点就是这个单词前缀的最后一个字母
//但其实有一个更好的方法,就是建立tri树的时候在树的节点里记录有几个单词经过这个节点,这样又可以从根节点遍历找到答案了。
//这是一个联系建立tri树的很好的机会
#include<iostream>
#include<stdio.h>
#include<cstring>
using namespace std;
struct Node
{
	int count;
	int son[26];
}node[20001];
char sour[1001][21];
int linenum=0;
int main()
{
	int currnode=0,alloc=0;
	memset(node,0,sizeof(node));
	while(scanf("%s",sour[linenum])!=EOF)
	{
		
		currnode=0;
		char cur;
		for(int i=0;cur=sour[linenum][i];i++)
		{
			cur-='a';
			int & next=node[currnode].son[cur]; //善于使用引用会很方便哦
			node[currnode].count++;
			if(!next)
			{
				next=++alloc;
			}
		    currnode=next;
		}
		node[currnode].count++;
		linenum++;

	}
	for(int i=0;i<linenum;i++)
	{
		currnode=0;
		char cur;
		bool fol=false;
		for(int j=0;cur=sour[i][j];j++)
		{
			cur-='a';
			currnode=node[currnode].son[cur];
			if(node[currnode].count==1)
			{
				printf("%s ",sour[i]);
				sour[i][j+1]=0;  //这就是输出的小技巧哦
				printf("%s\n",sour[i]);
				fol=true;
			}
			
		}
		if(!fol)
		{
			printf("%s ",sour[i]);
			printf("%s\n",sour[i]);

		}
	}
   
   return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值