PAT A 1019.General Palindromic Number (20)

题目

A number that will be the same when it is written forwards or backwards isknown as a Palindromic Number. For example, 1234321 is a palindromic number.All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimalsystem, the concept of palindromicity can be applied to the natural numbers inany numeral system. Consider a number N > 0 in base b >= 2, where it iswritten in standard notation with k+1 digits ai as the sum of (aibi)for i from 0 to k. Here, as usual, 0 <= ai < b for all i and akis non-zero. Then N is palindromic if and only if ai = ak-ifor all i. Zero is written 0 in any base and is also palindromic by definition.

Given any non-negative decimal integer N and a base b, you are supposed totell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of twonon-negative numbers N and b, where 0 <= N <= 109 is thedecimal number and 2 <= b <= 109 is the base. The numbers areseparated by a space.

Output Specification:

For each test case, first print in one line "Yes" if N is apalindromic number in base b, or "No" if not. Then in the next line,print N as the number in base b in the form "ak ak-1... a0". Notice that there must be no extra space at the end ofoutput.

Sample Input 1:

27 2

Sample Output 1:

Yes

1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No

4 4 1

 

将10进制数转换为相应进制,从两头扫一下就可以了。

 

代码:

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

int main()
{
	int i;
	long long n,b;	//N,b
	int digits;	//b下的数字位数
	cin>>n>>b;

	vector<long long> num_of_b;	//b下的数表示
	do	//求各位数
	{
		num_of_b.push_back(n%b);
		n/=b;
	}while(n>0);

	digits=num_of_b.size();	//求是否为GP-number
	for(i=0;i<digits;i++)
	{
		if(num_of_b[i]!=num_of_b[digits-i-1])
			break;
	}
	if(i<digits)	//输出
		cout<<"No"<<endl;
	else
		cout<<"Yes"<<endl;
	cout<<num_of_b.back();
	for(i=1;i<digits;i++)
		cout<<" "<<num_of_b[digits-i-1];

	return 0;
}


 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值