hdu 1050 Moving Tables(最大区间覆盖问题)

16 篇文章 0 订阅

 

Moving Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15906    Accepted Submission(s): 5470


Problem Description

 

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.  



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.  



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
 


 

Input

 

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
 


 

Output

 

The output should contain the minimum time in minutes to complete the moving, one per line.
 


 

Sample Input

 

  
  
3 4 10 20 30 40 50 60 70 80 2 1 3 2 200 3 10 100 20 80 30 50
 


 

Sample Output

 

  
  
10 20 30
 


题意:要求给你n个区间,每个都是将桌子从区间头一直搬到区间尾,且不可重叠,要求求出搬运完成至少需要多少时间。

思路:这就是一个求最大区间覆盖问题。求出最大求出覆盖数再乘以10,就是所需的最短时间啦

代码:

#include <cstdlib>
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
struct sa{
int s;
int e;
int flag;
}data[250];
bool cmp(sa a,sa b)
{
    if(a.s!=b.s)
        return a.s<b.s;
    else
        return a.e<b.e;
}

int main()
{
   int t,n,i,j,k;
 scanf("%d",&t);
 while(t--)
 {
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        scanf("%d%d",&data[i].s,&data[i].e);
        if(data[i].s>data[i].e)
            swap(data[i].s,data[i].e);
        data[i].flag=0;
    }
    sort(data,data+n,cmp);
    int count=0;
   for(i=0;i<n;i++)
   {
       if(data[i].flag==1) continue;
       count++;data[i].flag=1;
       int tmp=i;
       for(j=i+1;j<n;j++)
       {
           if(!data[j].flag&&data[j].s>data[tmp].e&&!(data[j].s%2==0&&(data[j].s-data[tmp].e==1)))
           {
               data[j].flag=1; tmp=j;
           }
       }


   }
   cout<<count*10<<endl;


 }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值