poj1328 Radar Installation

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

题目大意:x轴是海岸线,给出海岛的坐标和雷达的半径d,问最少在海岸线上安几个雷达可以覆盖所有的海岛.


思路:对于每一个海岛,雷达可以安装的范围就是以海岛为圆心,半径为d的圆与x轴的交点.对于每一个海岛,可以算出每一个雷达的范围,再根据范围相交的情况算出最少需要的雷达数.注意要用动态内存,否则会超出内存限制.


代码

#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
//Node 是x轴上的一个范围
struct Node{
    double Start;
    double End;
};


bool compare(struct Node n1,struct Node n2){
    return n1.Start<n2.Start;
}
int main()
{
    int n,r,i,num,Case=0,imp;
    double fin;
    while(scanf("%d %d",&n,&r)!=0&&n&&r){
        imp=0;num=1;
        int *x=new int[n];
        int *y=new int[n];
        struct Node *node=new struct Node[n];
        
        for(i=0;i<n;i++)
            scanf("%d %d",&x[i],&y[i]);
        for(i=0;i<n;i++){
            if(y[i]>r){
                imp=1;
                printf("Case %d: -1\n",++Case);
                break;
            }
        }
        if(imp)
            continue;
        //对于每一个海岛,算出可以安装雷达的范围
        for(i=0;i<n;i++){
            node[i].Start=x[i]-sqrt(r*r-y[i]*y[i]);
            node[i].End=x[i]+sqrt(r*r-y[i]*y[i]);
        }
        
        //对雷达的范围,以开始的坐标由小到大排序
        sort(node,node+n,compare);
        
        //fin是不需要增加雷达的最远坐标,如果有某一个范围开始的坐标超过了fin,则需要增加一个雷达,并更新fin
        fin=node[0].End;
        for(i=1;i<n;i++){
            if(fin>node[i].End){
                fin=node[i].End;
            }
            if(fin<node[i].Start){
                num++;
                fin=node[i].End;
            }
        }
        printf("Case %d: %d\n",++Case,num);
        delete []x;
        delete []y;
        delete []node;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值