poj1088 滑雪

Description

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子 
 1  2  3  4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9

一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。

Input

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

Output

输出最长区域的长度。

Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

25


思路:递推,用一个结构体储存每个点的坐标,高度,然后按高度由小到大排序.最后遍历每一点,如果这个点比周围的点高,而且步数小于或等于周围某个点的步数,则把这个点的步数加一.

#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;

struct Node{
    int x;
    int y;
    int h;
};
struct Node a[10001];
int steps[101][101],he[101][101];
bool compare(struct Node n1,struct Node n2){
    return n1.h<n2.h;
}
int main()
{
    memset(he,0,sizeof(he));
    int r,c,i,j,n=0,Max=0;
    scanf("%d %d",&r,&c);
    for(i=0;i<r;i++)
        for(j=0;j<c;j++){
        a[n].x=i;
        a[n].y=j;
        steps[i][j]=1;
        scanf("%d",&a[n].h);
        he[i][j]=a[n].h;
        n++;
        }
    sort(a,a+n,compare);
    for(i=0;i<n;i++){
        if(he[a[i].x+1][a[i].y]>he[a[i].x][a[i].y]&&steps[a[i].x][a[i].y]>=steps[a[i].x+1][a[i].y])
            steps[a[i].x+1][a[i].y]=steps[a[i].x][a[i].y]+1;
        if(he[a[i].x-1][a[i].y]>he[a[i].x][a[i].y]&&steps[a[i].x][a[i].y]>=steps[a[i].x-1][a[i].y])
            steps[a[i].x-1][a[i].y]=steps[a[i].x][a[i].y]+1;
        if(he[a[i].x][a[i].y+1]>he[a[i].x][a[i].y]&&steps[a[i].x][a[i].y]>=steps[a[i].x][a[i].y+1])
            steps[a[i].x][a[i].y+1]=steps[a[i].x][a[i].y]+1;
        if(he[a[i].x][a[i].y-1]>he[a[i].x][a[i].y]&&steps[a[i].x][a[i].y]>=steps[a[i].x][a[i].y-1])
            steps[a[i].x][a[i].y-1]=steps[a[i].x][a[i].y]+1;
    }
    for(i=0;i<r;i++)
        for(j=0;j<c;j++)
        if(steps[i][j]>Max)
        Max=steps[i][j];
    printf("%d\n",Max);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值