bit 1031 Binary Tree Traversals

Binary Tree Traversals

时间限制: 1秒  内存限制: 64M

ProblemDescription

A binary tree is a finite set of vertices that is eitherempty or consists of a root r and two disjoint binary trees called the left andright subtrees. There are three most important ways in which the vertices of abinary tree can be systematically traversed or ordered. They are preorder,inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.
In a preorder traversal of the vertices of T, we visit the root r followed byvisiting the vertices of T1 in preorder, then the vertices of T2 in preorder.
In an inorder traversal of the vertices of T, we visit the vertices of T1 ininorder, then the root r, followed by the vertices of T2 in inorder.
In a postorder traversal of the vertices of T, we visit the vertices of T1 inpostorder, then the vertices of T2 in postorder and finally we visit r.
Now you are given the preorder sequence and inorder sequence of a certainbinary tree. Try to find out its postorder sequence.

Input

The input contains several test cases. The first line ofeach test case contains a single integer n (1<=n<=1000), the number ofvertices of the binary tree. Followed by two lines, respectively indicating thepreorder sequence and inorder sequence. You can assume they are alwayscorrespond to a exclusive binary tree.

Output

For each test case print a single line specifying thecorresponding postorder sequence.

Sample Input

9

1 2 4 7 3 5 8 9 6

4 7 2 1 8 5 9 3 6

Sample Output

7 4 2 8 9 5 6 3 1

参考文章:二叉树前序、中序、后序遍历相互求法,

递归结束条件:当没有树不存在时结束,整棵树的节点数为0时结束

#include<stdio.h>
int flag  = 0;
void find_last(int *input_F,int *input_S,int num_node_tree){
	// num_node_tree :以input_F指向的节点为根节点的整棵树的节点数;
	int i;
	//当没有树不存在时结束,整棵树的节点数为0时结束;
	if(num_node_tree < 1){
		return ;		
	}
	//递归左、右树
	for(i  = 0;i < num_node_tree; ++i){
		if(input_F[0] == input_S[i]){
			break;
		}
	}		
	//左树
	find_last(&input_F[1],input_S,i);
	//右树
	find_last(&input_F[i+1],&input_S[i+1],num_node_tree - i -1);
	if(flag){
			printf(" %d",input_F[0]);
	}else{
			printf("%d",input_F[0]);
			flag = 1;
	}

	return ;
}
int main(){
	int input_F[2003];
	int input_S[2003];
	int input_num;
	int i;

	//FILE *fp;
//	fp = freopen("in.txt","r",stdin);

	while(~scanf("%d",&input_num)){

		for(i = 0;i < input_num;++i){
			scanf("%d",&input_F[i]);
		}
		for(i = 0;i < input_num;++i){
			scanf("%d",&input_S[i]);
		}
		flag = 0;
		find_last(input_F,input_S,input_num);
		printf("\n");
		//tree->elem = input_F[0]; 
		//temp->elem = input_F[0];
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值