Binary Tree Traversals

H - Binary Tree Traversals
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2. 

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder. 

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r. 

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence. 
 

Input

The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree. 
 

Output

For each test case print a single line specifying the corresponding postorder sequence. 
 

Sample Input

       
       
9 1 2 4 7 3 5 8 9 6 4 7 2 1 8 5 9 3 6
 

Sample Output

       
       
7 4 2 8 9 5 6 3 1
 

先序中序求后序的模板题

#include <string.h>
#include <stdio.h>
#include <iostream>
#include <stdlib.h>
#define N 1002
using namespace std;

struct tree
{
    int data;
    struct tree *right, *left;
};
int ok;

struct tree *create( int len, int *Pr, int *In )
{
    int i;
    struct tree *root;
    root = (struct tree *)malloc(sizeof(struct tree));
    if ( len == 0 )
    {
        return root = NULL;
    }

    root->data = Pr[0];
    for ( i = 0;i < len ; i++ )
    {
        if ( Pr[0] == In[i] )
            break;
    }

    root->left = create ( i, Pr+1, In );
    root->right = create ( len-i-1, Pr+i+1, In+i+1 );

    return root;
}

void AFTER_order ( struct tree *root )
{
    if ( root )
    {
        AFTER_order ( root->left );
        AFTER_order ( root->right );
        if ( ok == 0 )
        {
            printf ( "%d", root->data );
            ok = 1;
        }
        else
            printf(" %d", root->data );
    }
}

int main()
{
    int t, i;
    int Pr[N], In[N];

    while ( ~scanf ( "%d", &t ) )
    {

        for( i = 0;i < t ; i++ )
        {
            scanf ( "%d", &Pr[i] );
        }
        for( i = 0;i < t ; i++ )
        {
            scanf ( "%d", &In[i] );
        }

        struct tree *root;

        root = create ( t, Pr, In );

        ok = 0;
        AFTER_order ( root );
        printf ( "\n" );
    }
    return 0;
}

代码菜鸟,如有错误,请多包涵!!!




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值