B - Simpsons’ Hidden Talents

B - Simpsons’ Hidden Talents

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.

Sample Input

clinton

homer

riemann

marjorie

Sample Output

0

rie 3

题意概括  :

输入两个字符串,判断第一个字符串的前缀是第二个字符串后缀的长度,输出前缀及其长度,如果没有输出0.

解题思路  :

首先,求出第一个字符串的next数组,然后两个字符串进行匹配,控制第一个字符串下表最终的值就是两个字符串前后缀相等的长度。

#include<stdio.h>
#include<string.h>

char s1[51000],s2[51000];
int next[51000];

void get_next(char s1[])
{
	int i,j,len;
	
	i = 1;
	j = 0;
	len = strlen(s1);
	next[0] = 0;
	
	while(i < len)
	{
		if(j == 0&&s1[i] != s1[j])
		{
			i ++;
		}
		if(j > 0&&s1[i] != s1[j])
		{
			j = next[j-1];
		}
		if(s1[i] == s1[j])
		{
			next[i] = j+1;
			i ++;
			j ++;
		}
	}
}
int KMP(char s1[],char s2[])
{
	int i,j,lens1,lens2;
	
	i = 0;
	j = 0;
	lens1 = strlen(s1);
	lens2 = strlen(s2);
	
	while(j < lens2)
	{
		if(i == 0&&s1[i] != s2[j])
		{
			j ++;
		}
		if(i > 0&&s1[i] != s2[j])
		{
			i = next[i-1];
		}
		if(s1[i] == s2[j])
		{
			i ++;
			j ++;
		}
	}
	return i;
}
int main()
{
	int t,i;
	
	while(~ scanf("%s",s1))
	{
		memset(next,0,sizeof(next));
		scanf("%s",s2);
		get_next(s1);
		t = KMP(s1,s2);
		
		for(i = 0;i < t;i ++)
		{
			printf("%c",s1[i]);
		}
		if(t != 0)
		printf(" ");
		printf("%d\n",t);
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值