Simpsons’ Hidden Talents

Simpsons’ Hidden Talents
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6687 Accepted Submission(s): 2396

Problem Description
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.

Sample Input
clinton
homer
riemann
marjorie

Sample Output
0
rie 3

Source
HDU 2010-05 Programming Contest
计算前缀和后缀的最长长度,注意不要用next做数组

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <queue>
#define N 50010
using namespace std;
int nex[N];
int nextt[N];
char s1[N];
char s2[N];
void get_next(char *p)
{
    /*int q,k,m;
    m=strlen(p);
    next[0]=0;
    for(q=1,k=0;q<m;++k)
    {
        while(k&&p[q]!=p[k])
        k=next[k-1];
        if(p[q]==p[k])
        k++;
        next[q]=k;
    }*/
    int j,k;
    j=0;
    k=-1;
    int len=strlen(p);
    nextt[0]=-1;
    while(j<len)
    {
        if(k==-1||p[j]==p[k])
        {
            j++,k++;
            nextt[j]=k;
        }
        else
        k=nextt[k];
    }
}
void kmp(char *p,char *q)
{
    int len2=strlen(q);
    get_next(p);
    int i,k;
    nex[0]=0;
    i=0,k=0;
    while(i<len2)
    {
        if(k==-1||p[k]==q[i])
        {
            i++,k++;
            nex[i]=k;
        }
        else k=nextt[k];
    }

}
int main()
{
    while(scanf("%s%s",s1,s2)!=EOF)
    {
        kmp(s1,s2);
        int n=strlen(s2);
        if(nex[n]==0)
        printf("0\n");
        else
        {
            for(int i=0;i<nex[n];i++)
            printf("%c",s1[i]);
            printf(" %d\n",nex[n]);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值