K - Wormholes

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2

3 3 1

1 2 2

1 3 4

2 3 1

3 1 3

3 2 1

1 2 3

2 3 4

3 1 8

Sample Output

NO

YES

 

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题意概括  :

农民约翰探索农场时发现许多虫洞,m个普通虫洞可以把你送到相应的时间后,w个特殊虫洞,可以回到所对应得时间之前。

解题思路  :

将各个虫洞得权值和对应的农场坐标存入数组中,时间向前的记为正,时间向后的记为负,判断是否存在相应的负权边。

#include<stdio.h>
#include<string.h>

int a[505][505];
int inf = 99999999;
int n,m,w;

int main()
{
	int T,i,j,k,s,e,t,flag;
	
	scanf("%d",&T);
	while(T --)
	{
		scanf("%d %d %d",&n,&m,&w);
		flag = 0;
		for(i = 1;i<=n;i ++)
		{
			for(j = 1;j<=n;j ++)
			{
				if(i == j)
				a[i][j] = 0;
				else
				a[i][j] = inf;
			}
		}
		for(i = 1;i<=m;i ++)
		{
			scanf("%d %d %d",&s,&e,&t);
			if(a[s][e] > t)
			a[s][e] = a[e][s] = t;
		}
		for(i = m+1;i<=m+w;i ++)
		{
			scanf("%d %d %d",&s,&e,&t);
			if(a[s][e]>-t)
			a[s][e] = -t;
		}
		
		for(k = 1;k<=n;k ++)
		{
			for(i = 1;i<=n;i ++)
			{
				for(j = 1;j<=n;j ++)
				{
					if(a[i][j]>a[i][k]+a[k][j])
					a[i][j] = a[i][k]+a[k][j];
				}
				if(a[i][i] < 0)
				{
					flag = 1;
					break;
				}
			}
			if(flag == 1)
			break;
		}
		if(flag == 1)
		printf("YES\n");
		else
		printf("NO\n");
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值