F - Wireless Network(并查集 判断根节点是否相同)

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. "O p" (1 <= p <= N), which means repairing computer p.
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1

0 1

0 2

0 3

0 4

O 1

O 2

O 4

S 1 4

O 3

S 1 4

Sample Output

FAIL

SUCCESS

  • 题意概括  :

给你n台坏的计算机,然后两台计算机最大通信范围为d,修理网络时,工人可以在每一时刻采取两种操作,修理一台计算机,或者测试两台计算机是否能够通信。如果能够通信输出success否则输出fail。

  • 解题思路  :

首先,工人的操作是测试还是修理,如果是修理,将已经修理好的用book数组标记,然后判断两台电脑之间的距离是否满足题意,并且判断前一台电脑是否修好,最后如果是测试,判断两台电脑的根节点是否相同,如果相同则证明可以通信。

#include<stdio.h>
#include<string.h>

int f[1010],book[1010];
int n,m;
char s[2];

struct node
{
	int x,y;
}que[1000];

int getf(int v)
{
	if(f[v] != v)
	f[v] = getf(f[v]);
	return f[v];
}

int merge(int v,int u)
{
	int t1,t2;
	
	t1 = getf(v);
	t2 = getf(u);
	
	if(t1 != t2)
	{
		f[t2] = t1;
	}
}
int main()
{
	int i,j,a,b;
	
	while(~ scanf("%d %d",&n,&m))
	{
		memset(book,0,sizeof(book));
		for(i = 1;i<=n;i ++)
		{
			f[i] = i;
		}
		for(i = 1;i<=n;i ++)
		{
			scanf("%d %d",&que[i].x,&que[i].y);
		}
		
		while(~ scanf("%s",s))
		{
			if(s[0] == 'O')
			{
				scanf("%d",&a);
				if(book[a] == 0)
				{
					book[a] = 1; 
					for(i = 1;i<=n;i ++)
					{
						if(book[i]==1&&i != a&&(que[a].x - que[i].x)*(que[a].x - que[i].x)+(que[a].y - que[i].y)*(que[a].y- que[i].y)<=m*m)
						{
							merge(a,i);
						}
					}
				}
				else
				continue;
			}
			else
			{
				scanf("%d %d",&a,&b);
				if(getf(a) == getf(b))
				printf("SUCCESS\n");
				else
				printf("FAIL\n");
			}
		}
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值