POJ2236 Wireless Network【并查集】

Wireless Network

Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 39279 Accepted: 16280

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

问题链接:POJ2236 Wireless Network

问题描述:有n台电脑(从1开始编号),用二维坐标描述这n台电脑的位置,给定通信范围d,电脑A可以和与电脑A相距在d以内的电脑B直接通信,电脑通信可以以某台电脑为中间媒介,例如,A和B相距大于d不能直接通信,但是如果A和C可通信,C又可与B通信,则A和B可间接通信。由于余震的影响,这n台电脑都坏掉了,现在要逐个进行修理,O x表示修理编号为x的电脑,S x y表示查询电脑x和电脑y是否可通信,如果可以通信输出SUCCESS,否则输出FALL,注意只有维修好的电脑才能进行通信

解题思路:简单并查集,用vis数组记录电脑是否被维修好,每维修好一台电脑,就让这台电脑与之前修理好的电脑进行操作,如果它们之间的距离在d内就进行连接,具体看程序

AC的C++程序:

#include<iostream>
#include<cmath>
#include<cstring> 

using namespace std;

const int N=1005;

struct Node{
	double x,y;
}a[N];

int pre[N];
bool vis[N];//vis[i]=true 表示计算机i被修复 

void init(int n)
{
	for(int i=0;i<=n;i++)
	  pre[i]=i;
}

int find(int x)
{
	int r=x;
	while(r!=pre[r])
	  r=pre[r];
	//路径压缩
	while(x!=r){
		int i=pre[x];
		pre[x]=r;
		x=i;
	} 
	return r;
}

void join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	  pre[fx]=fy;
}

double dist(int p1,int p2)
{
	return sqrt((a[p1].x-a[p2].x)*(a[p1].x-a[p2].x)+(a[p1].y-a[p2].y)*(a[p1].y-a[p2].y));
}

int main()
{
	double d;
	char c;
	int p,q,n;
	scanf("%d%lf",&n,&d);
	for(int i=1;i<=n;i++)
	  scanf("%lf%lf",&a[i].x,&a[i].y);
	memset(vis,false,sizeof(vis));
	init(n);
	while(scanf(" %c",&c)!=EOF){
		if(c=='O'){
			scanf("%d",&p);
			vis[p]=true;
			for(int i=1;i<=n;i++)
			  if(i!=p&&vis[i]&&dist(p,i)<=d)
			  	join(p,i);
		}
		else if(c=='S'){
			scanf("%d%d",&p,&q); 
			if(find(p)==find(q))
			  printf("SUCCESS\n");
			else
			  printf("FAIL\n");
		}
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值