I - Dragon Balls(并查集 按秩合并)

Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together.


His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.

Input

The first line of the input is a single positive integer T(0 < T <= 100).
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)

Output

For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.

Sample Input

2

3 3

T 1 2

T 3 2

Q 2

3 4

T 1 2

Q 1

T 1 3

Q 1

Sample Output

Case 1:

2 3 0

Case 2:

2 2 1

3 3 2

  • 题意概括  :

寻找龙珠,每次带着全部龙珠从一个城市移动到另一个城市,每个城市原本只有一颗龙珠,每走一个城市,需要移动一步,两种操作,一种是把龙珠移动,一种是询问城市中有几颗龙珠,以及移动的步数。

  • 解题思路  :

记录移动次数,把自己的加上父节点的就是移动总数了。而龙珠的个数用到了按秩合并。

#include<stdio.h>
#include<string.h>

int n,m;
int f[10010],num[10010],move[10010];


int getf(int v)
{
	int t;
	
	if(f[v] == -1)
	return v;
	
	t = f[v];
	f[v] = getf(f[v]);
	move[v] += move[t];
	
	return f[v];
}
int merge(int v,int u)
{
	int t1,t2;
	
	t1 = getf(v);
	t2 = getf(u);
	
	if(t1 != t2)
	{
		f[t1] = t2;
		num[t2] += num[t1];
		move[t1] = 1;
	}
}
int main()
{
	int T,i,j,a,b,iCase = 0;
	char s[10];
	
	scanf("%d",&T);
	while(T --)
	{
		iCase ++;
		
		scanf("%d %d",&n,&m);
		
		for(i = 1;i<=n;i ++)
		{
			f[i] = -1;
			num[i] = 1;
			move[i] = 0; 
		}
		
		printf("Case %d:\n",iCase);
		while(m --)
		{
			scanf("%s",s);
			
			if(s[0] == 'T')
			{
				scanf("%d %d",&a,&b);
				
				merge(a,b);
			}
			else
			{
				scanf("%d",&a);
				int t = getf(a);
				printf("%d %d %d\n",t,num[t],move[a]);
			}
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值