poj 1300 Door Man

Door Man
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 1717 Accepted: 647

Description

You are a butler in a large mansion. This mansion has so many rooms that they are merely referred to by number (room 0, 1, 2, 3, etc...). Your master is a particularly absent-minded lout and continually leaves doors open throughout a particular floor of the house. Over the years, you have mastered the art of traveling in a single path through the sloppy rooms and closing the doors behind you. Your biggest problem is determining whether it is possible to find a path through the sloppy rooms where you: 

  1. Always shut open doors behind you immediately after passing through 
  2. Never open a closed door 
  3. End up in your chambers (room 0) with all doors closed 

In this problem, you are given a list of rooms and open doors between them (along with a starting room). It is not needed to determine a route, only if one is possible. 

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. 
A single data set has 3 components: 

  1. Start line - A single line, "START M N", where M indicates the butler's starting room, and N indicates the number of rooms in the house (1 <= N <= 20). 
  2. Room list - A series of N lines. Each line lists, for a single room, every open door that leads to a room of higher number. For example, if room 3 had open doors to rooms 1, 5, and 7, the line for room 3 would read "5 7". The first line in the list represents room 0. The second line represents room 1, and so on until the last line, which represents room (N - 1). It is possible for lines to be empty (in particular, the last line will always be empty since it is the highest numbered room). On each line, the adjacent rooms are always listed in ascending order. It is possible for rooms to be connected by multiple doors! 
  3. End line - A single line, "END" 

Following the final data set will be a single line, "ENDOFINPUT". 

Note that there will be no more than 100 doors in any single data set.

Output

For each data set, there will be exactly one line of output. If it is possible for the butler (by following the rules in the introduction) to walk into his chambers and close the final open door behind him, print a line "YES X", where X is the number of doors he closed. Otherwise, print "NO".

Sample Input

START 1 2
1

END
START 0 5
1 2 2 3 3 4 4




END
START 0 10
1 9
2
3
4
5
6
7
8
9

END
ENDOFINPUT

Sample Output

YES 1
NO
YES 10

Source


题目意思很好懂就说有很多开着的门。问是否存在一条路把所有的门都关掉。(每条路只能走一次)这题直接判断每个节点的度数和起始位置是否为home就行。

难点是输入不好处理。

#include <stdio.h>
#include<string.h>
int door[150],ok[150];//door记录每个门的度数。ok记录度数为奇数节点的位置
char c;//设置成全局变量方便查看其值

int getint()//读一个整数的函数
{
    int s;
    c=getchar();
    if(c=='\n')//遇到换行就返回
        return -1;
    while(c==' ')
        c=getchar();
    s=0;
    while(c>='0'&&c<='9')//将字符转换为数字
    {
        s*=10;
        s+=c-'0';
        c=getchar();
    }
    return s;
}
int main()
{
    int m,n,b,i,sum,cnt;
    char s[10];

    while(~scanf("%s",s))
    {
        if(s[3]=='O')//判断是否结束
            break;
        scanf("%d%d",&m,&n);
        getchar();
        sum=cnt=0;
        memset(door,0,sizeof door);
        for(i=0; i<n; i++)
        {
            do
            {
                b=getint();
                if(b==-1)
                    break;
                door[i]++;//第i个房间度数加1
                door[b]++;//第b个房间度数加1
                sum++;//门数加1
            }while(c!='\n');//对于空行的处理。和数据尾换行的处理
        }
        scanf("%s",s);
        for(i=0; i<n; i++)
        {
            if(door[i]%2!=0)//获取奇度点数据
                ok[cnt++]=i;
        }
        if((m==0&&cnt==0)||(m!=0&&cnt==2&&ok[0]==0&&ok[1]==m))//判断欧拉回路和欧拉路径
            printf("YES %d\n",sum);
        else
            printf("NO\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值