USTH-第三次测试-1004-Revenge of Segment Tree

Revenge of Segment Tree
Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 23   Accepted Submission(s) : 7
Problem Description
In computer science, a segment tree is a tree data structure for storing intervals, or segments. It allows querying which of the stored segments contain a given point. It is, in principle, a static structure; that is, its content cannot be modified once the structure is built. A similar data structure is the interval tree.
A segment tree for a set I of n intervals uses O(n log n) storage and can be built in O(n log n) time. Segment trees support searching for all the intervals that contain a query point in O(log n + k), k being the number of retrieved intervals or segments.
---Wikipedia

Today, Segment Tree takes revenge on you. As Segment Tree can answer the sum query of a interval sequence easily, your task is calculating the sum of the sum of all continuous sub-sequences of a given number sequence.

Input
The first line contains a single integer T, indicating the number of test cases.  Each test case begins with an integer N, indicating the length of the sequence. Then N integer Ai follows, indicating the sequence. [Technical Specification] 1. 1 <= T <= 10 2. 1 <= N <= 447 000 3. 0 <= Ai <= 1 000 000 000

Output
For each test case, output the answer mod 1 000 000 007.

Sample Input
 
 
2 1 2 3 1 2 3

Sample Output
 
 
2 20 [hint]For the second test case, all continuous sub-sequences are [1], [2], [3], [1, 2], [2, 3] and [1, 2, 3]. So the sum of the sum of the sub-sequences is 1 + 2 + 3 + 3 + 5 + 6 = 20. Huge input, faster I/O method is recommended. And as N is rather big, too straightforward algorithm (for example, O(N^2)) will
lead Time Limit Exceeded. And one more little helpful hint, be careful about the overflow of int.[/hint]

Source
BestCoder Round #16
 
 
 
 
 
 
根据出现次数,一句话分布规律:
ans = (ans + (i * (N - i + 1) % mod) * (x % mod)) % mod;
就是这么简单的次数规律,跟线段数没有半毛钱关系;
 
 
 
 
 
 
S:
#include <stdio.h>
#include <iostream>

using namespace std;

long long N;
const long long mod = 1000000007;

int main()
{
    int t;

    scanf("%d", &t);

    while(t--)
    {
          long long x;
          long long ans = 0;

          scanf("%I64d", &N);
          for(long long i = 1; i <= N; i++)
          {
              scanf("%I64d", &x);
              ans = (ans + (i * (N - i + 1) % mod) * (x % mod)) % mod;
          }
          printf("%I64d\n", ans);
    }

  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值