Primary Arithmetic

FJNU.1531
PKU.2562

Description
Children are taught to add multi-digit numbers from right-to-left one digit at a time. Many find the "carry" operation - in which a 1 is carried from one digit position to be added to the next - to be a significant challenge. Your job is to count the number of carry operations for each of a set of addition problems so that educators may assess their difficulty.

Input
Each line of input contains two unsigned integers less than 10 digits. The last line of input contains 0 0.

Output
For each line of input except the last you should compute and print the number of carry operations that would result from adding the two numbers, in the format shown below.

Sample Input
123 456
555 555
123 594
0 0

Sample Output
No carry operation.
3 carry operations.
1 carry operation.

Source
23 September, 2000 - Waterloo

My Program

#include < iostream >
#define  N 10
using   namespace  std;

int  main()
{
    
int c[N+1],d[N+1];
    
int m,n,i,k;
    
long a,b;
    
while(cin>>a>>b)
    
{
        
for(i=0;i<=N;i++)
            c[i]
=d[i]=0;
        
if(a==0&&b==0)
            
break;
        m
=n=N;k=0;
        
while(a>0)
        
{
            c[m]
=a%10;
            a
/=10;
            m
--;
        }

        
while(b>0)
        
{
            d[n]
=b%10;
            b
/=10;
            n
--;
        }

        
for(i=N;i>0;i--)
        
{
            d[i]
+=c[i];
            
if(d[i]>=10)
            
{
                k
++;
                d[i
-1]++;
                d[i]
%=10;
            }

        }

        
if(k==0)
            cout
<<"No carry operation."<<endl;
        
else
            
if(k==1)
                cout
<<"1 carry operation."<<endl;
            
else
                cout
<<k<<" carry operations."<<endl;
    }

    
return 0;
}

YOYO's Note: 
计算有多少次进位,虽然它只是10位,我还是用了数组 = = ||
不知道有没有其他更简单的方法……?或许直接加了比较是否会好些?懒得去试了……
注意输出时0、单数、复数的格式。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值