POJ 1852 蚂蚁在杆上走

4 篇文章 0 订阅
[NWPU2015][SRM][02][div2]三一五专场
2:00:00
E - E
Time Limit:1000MS    Memory Limit:30000KB    64bit IO Format:%I64d & %I64u

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207


这是一道经典题,挑战书上也有,就是蚂蚁相遇时可以视作没有影响,还是沿原来的方向前进。所以

最短距离就是各自朝最近的一端走

最远距离就是两端的蚂蚁向对面一端走,然后取二者最大值

//@auther yangZongJun
/********************************************//**
Date  : 2014/03/08
题目来源:
题    意:
解题思路:
 ***********************************************/
#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <string>
#include <cstring>

using namespace std;
#define PI acos(-1.0)
#define EPS 1e-8
const int MAXN = 1000000+5;
const int INF = 2100000000;

int cas;
int a;
int len, n ,shortest[MAXN];


int main()
{
    //freopen("input.txt", "r", stdin);
    scanf("%d", &cas);
    while(cas--)
    {
        int  mina = INF, maxa = -1;
        scanf("%d%d", &len, &n);
        for(int i = 0; i <n; i++)
        {
            scanf("%d", &a);
            shortest[i] = min(a, len-a);
            if(a < mina)
            {
                mina = a;
            }
            if(a > maxa)
            {
                maxa = a;
            }
        }
        int t1 = -1;
        for(int i = 0; i < n; i++)
        {
            if(shortest[i] > t1)
            {
                t1 = shortest[i];
            }
        }
        printf("%d ", t1);
        int tt1 = max(mina, len-mina);
        int tt2 = max(maxa, len-maxa);
        printf("%d\n", max(tt1, tt2));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值