POJ 3673

[NWPU][2014][TRN][1]水题堆
7:30:00
                   
B - Cow Multiplication
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Bessie is tired of multiplying pairs of numbers the usual way, so she invented her own style of multiplication. In her style, A*B is equal to the sum of all possible pairwise products between the digits of A and B. For example, the product 123*45 is equal to 1*4 + 1*5 + 2*4 + 2*5 + 3*4 + 3*5 = 54. Given two integers A and B (1 ≤ A, B ≤ 1,000,000,000), determine A*B in Bessie's style of multiplication.

Input

* Line 1: Two space-separated integers: A and B.

Output

* Line 1: A single line that is the A*B in Bessie's style of multiplication.

Sample Input

123 45

Sample Output

54


开始用读入数字来解,比较复杂

//@auther Yang Zongjun
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <string>

using namespace std;
#define PI acos(-1.0)
#define EPS 1e-8
const int MAXN = 1100000;
const int INF = 2100000000;
int a, b;


int main()
{
    //freopen("C:/Users/Administrator/Desktop/input.txt", "r", stdin);
    while(~scanf("%d%d", &a, &b))
    {
        int ans = 0;
        while(a != 0)
        {
            int t = a % 10;
            a /= 10;
            int m = b;
            while(m != 0)
            {
                int temp = m % 10;
                m /= 10;
                ans += t * temp;
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}

后来发现用string类更简单,啊哈哈

//@auther Yang Zongjun
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <string>

using namespace std;
#define PI acos(-1.0)
#define EPS 1e-8
const int MAXN = 1100000;
const int INF = 2100000000;
string s1, s2;


int main()
{
    freopen("C:/Users/Administrator/Desktop/input.txt", "r", stdin);
    while(cin >> s1 >> s2)
    {
        int lens1 = s1.length();
        int lens2 = s2.length();
        int ans = 0;
        for(int i = 0; i < lens1; i++)
        {
            for(int j = 0; j < lens2 ;j++)
            {
                ans += (s1[i] - '0') * (s2[j]- '0' );
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值