Recaman's Sequence |
Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:65536KB |
Total submit users: 549, Accepted users: 471 |
Problem 10010 : No special judgement |
Problem description |
The Recaman's sequence is defined by a0 = 0 ; for m > 0, am = am−1 − m if the rsulting am is positive and not already in the sequence, otherwise am = am−1 + m. The first few numbers in the Recaman's Sequence is 0, 1, 3, 6, 2, 7, 13, 20, 12, 21, 11, 22, 10, 23, 9 ... Given k, your task is to calculate ak. |
Input |
The input consists of several test cases. Each line of the input contains an integer k where 0 <= k <= 500000. The last line contains an integer −1, which should not be processed. |
Output |
For each k given in the input, print one line containing ak to the output. |
Sample Input |
7 10000 -1 |
Sample Output |
20 18658 |
Problem Source |
Shanghai-P 2004 |
CODE
/*
Name: 10010_Recaman's Sequence
Copyright: yangchun's
Author: yangchun
Date: 20-06-08 22:27
Description: HUNAN UNIVERSITY ACM/ICPC Judge Online_Problem 10010_Recaman's Sequence
*/
#include <algorithm>
#include <iostream>
using namespace std;
long sequence[500000];
int _sequence[5000000];
int main()
{
// freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
sequence[0] = 0;
for(long m=1; m<500000; m++)
{
sequence[m] = sequence[m-1] - m;
if(sequence[m] <=0 || _sequence[sequence[m]] == 1)
sequence[m] = sequence[m-1] + m;
_sequence[sequence[m]] = 1;
}
long n=0;
while(scanf("%d",&n),n!=-1)
printf("%ld/n",sequence[n]);
return 0;
}