HUNAN UNIVERSITY ACM/ICPC Judge Online_Problem 10010_Recaman's Sequence

Recaman's Sequence
Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:65536KB
Total submit users: 549, Accepted users: 471
Problem 10010 : No special judgement
Problem description
The Recaman's sequence is defined by a0 = 0 ; for m > 0, am = am−1 − m if the rsulting am is positive and not already in the sequence, otherwise am = am−1 + m. The first few numbers in the Recaman's Sequence is 0, 1, 3, 6, 2, 7, 13, 20, 12, 21, 11, 22, 10, 23, 9 ... Given k, your task is to calculate ak.
Input
The input consists of several test cases. Each line of the input contains an integer k where 0 <= k <= 500000. The last line contains an integer −1, which should not be processed.
Output
For each k given in the input, print one line containing ak to the output.
Sample Input
7
10000
-1
Sample Output
20
18658
Problem Source
Shanghai-P 2004

CODE

/*

  Name:  10010_Recaman's Sequence

  Copyright:  yangchun's

  Author:  yangchun

  Date:  20-06-08 22:27

  Description:  HUNAN UNIVERSITY ACM/ICPC Judge Online_Problem 10010_Recaman's Sequence

*/



#include <algorithm>

#include <iostream>



using namespace std;



long sequence[500000];

int _sequence[5000000];



int main()

{

   // freopen("in.txt","r",stdin);

    //freopen("out.txt","w",stdout);

    

    sequence[0] = 0;

    for(long m=1; m<500000; m++)

    {

        sequence[m] = sequence[m-1] - m;

        if(sequence[m] <=0 || _sequence[sequence[m]] == 1)

            sequence[m] = sequence[m-1] + m;

        _sequence[sequence[m]] = 1;

    }

    

    long n=0;

    while(scanf("%d",&n),n!=-1)

        printf("%ld/n",sequence[n]);

    

    return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值