Jolly Jumpers |
Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:32768KB |
Total submit users: 557, Accepted users: 491 |
Problem 10050 : No special judgement |
Problem description |
A sequence of n > 0 integers is called a jolly jumper if the absolute values of the difference between successive elements take on all the values 1 through n-1. For instance, 1 4 2 3 is a jolly jumper, because the absolutes differences are 3, 2, and 1 respectively. The definition implies that any sequence of a single integer is a jolly jumper. You are to write a program to determine whether or not each of a number of sequences is a jolly jumper. |
Input |
Each line of input contains an integer n < 3000 followed by n integers representing the sequence. |
Output |
For each line of input, generate a line of output saying "Jolly" or "Not jolly". |
Sample Input |
4 1 4 2 3 5 1 4 2 -1 6 |
Sample Output |
Jolly Not jolly |
Problem Source |
Waterloo 2000 |
CODE
/*
Name: 10050_Jolly Jumpers
Copyright: yangchun's
Author: yangchun
Date: 22-06-08 00:51
Description: HUNAN UNIVERSITY ACM/ICPC Judge Online_Problem 10050_Jolly Jumpers
Other: 1到n-1,不是在这个范围内啊。是全部要有...
*/
#include <algorithm>
#include <iostream>
using namespace std;
int main()
{
//freopen("in.txt","r",stdin);
// freopen("out.txt","w",stdout);
int i,n,temp,sequence[3000],abs_value[3000];
while(scanf("%d",&n)!=EOF)
{
for(i=0; i<n; i++)
scanf("%d",&sequence[i]);
memset(abs_value,0,sizeof(abs_value));
for(i=0; i<n-1; i++)
{
temp = (sequence[i+1] >= sequence[i])?(sequence[i+1] - sequence[i]):(sequence[i] - sequence[i+1]);
if(temp<n) abs_value[temp] = 1;
}
for(i=1; i<n; i++)
if(abs_value[i]==0) break;
if(i==n) printf("Jolly/n");
else printf("Not jolly/n");
}
return 0;
}