HUNAN UNIVERSITY ACM/ICPC Judge Online_Problem 10050_Jolly Jumpers

Jolly Jumpers
Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:32768KB
Total submit users: 557, Accepted users: 491
Problem 10050 : No special judgement
Problem description
A sequence of n > 0 integers is called a jolly jumper if the absolute values of the difference between successive elements take on all the values 1 through n-1. For instance, 1 4 2 3 is a jolly jumper, because the absolutes differences are 3, 2, and 1 respectively. The definition implies that any sequence of a single integer is a jolly jumper. You are to write a program to determine whether or not each of a number of sequences is a jolly jumper.
Input
Each line of input contains an integer n < 3000 followed by n integers representing the sequence.
Output
For each line of input, generate a line of output saying "Jolly" or "Not jolly".
Sample Input
4 1 4 2 3
5 1 4 2 -1 6
Sample Output
Jolly
Not jolly
Problem Source
Waterloo 2000

CODE

/*

  Name:  10050_Jolly Jumpers

  Copyright:  yangchun's

  Author:  yangchun

  Date:  22-06-08 00:51

  Description:  HUNAN UNIVERSITY ACM/ICPC Judge Online_Problem 10050_Jolly Jumpers

  Other:  1到n-1,不是在这个范围内啊。是全部要有... 

*/



#include <algorithm>

#include <iostream>



using namespace std;



int main()

{

    //freopen("in.txt","r",stdin);

   // freopen("out.txt","w",stdout);

    

    int i,n,temp,sequence[3000],abs_value[3000];

    

    while(scanf("%d",&n)!=EOF)

    {

        for(i=0; i<n; i++)

            scanf("%d",&sequence[i]);

        

        memset(abs_value,0,sizeof(abs_value));

        

        for(i=0; i<n-1; i++)

        {

            temp = (sequence[i+1] >= sequence[i])?(sequence[i+1] - sequence[i]):(sequence[i] - sequence[i+1]);

            if(temp<n)    abs_value[temp] = 1;

        }

        

        for(i=1; i<n; i++)

            if(abs_value[i]==0)    break;

        if(i==n)    printf("Jolly/n");

        else    printf("Not jolly/n"); 

    }

    

    return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值