HUNAN UNIVERSITY ACM/ICPC Judge Online_Problem 10013_Calendar

Calendar
Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:32768KB
Total submit users: 441, Accepted users: 375
Problem 10013 : No special judgement
Problem description
A calendar is a system for measuring time, from hours and minutes, to months and days, and finally to years and centuries. The terms of hour, day, month, year and century are all units of time measurements of a calender system. According to the Gregorian calendar, which is the civil calendar in use today, years evenly divisible by 4 are leap years, with the exception of centurial years that are not evenly divisible by 400. Therefore, the years 1700, 1800, 1900 and 2100 are not leap years, but 1600, 2000, and 2400 are leap years. Given the number of days that have elapsed since January 1, 2000 A.D, your mission is to find the date and the day of the week.
Input
The input consists of lines each containing a positive integer, which is the number of days that have elapsed since January 1, 2000 A.D. The last line contains an integer −1, which should not be processed. You may assume that the resulting date won’t be after the year 9999.
Output
For each test case, output one line containing the date and the day of the week in the format of "YYYY-MM-DD DayOfWeek", where "DayOfWeek" must be one of "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday" and "Saturday".
Sample Input
1730
1740
1750
1751
-1
Sample Output
2004-09-26 Sunday
2004-10-06 Wednesday
2004-10-16 Saturday
2004-10-17 Sunday
Problem Source
Shanghai-P 2004

CODE

/*

  Name:  10013_Calendar

  Copyright:  yangchun's

  Author:  yangchun

  Date:  22-06-08 09:15

  Description:  HUNAN UNIVERSITY ACM/ICPC Judge Online_Problem 10013_Calendar

*/



#include <algorithm>

#include <iostream>

#include <time.h>



using namespace std;



int main()

{

    //freopen("in.txt","r",stdin);

    //freopen("out.txt","w",stdout);

    

    int i = 0, j = 0, years[8000] = {0}, _year = 0, _month = 0, _day = 0, _weekday = 0, 

        days[2][13] = {365,31,28,31,30,31,30,31,31,30,31,30,31,366,31,29,31,30,31,30,31,31,30,31,30,31};   

    long n;

    char weekdays[7][10] = {"Saturday", "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday" };

    

    for(i=0; i<8000; i++)

    {

        int temp = 2000 + i;

        if( (temp % 4 == 0 && temp % 100 !=0) || temp % 400 == 0)

            years[i] = 1;

    }

    

    while(scanf("%d",&n),n!=-1)

    {

        n++;

        _weekday = (n-1) % 7;

        

        for(i=0; n>days[years[i]][0]; i++)

            n -= days[years[i]][0];            

        _year = 2000 + i;

        

        for(j=1; n>days[years[i]][j]; j++)

            n -= days[years[i]][j];

        _month = j;

        

        _day = n;

        

        printf("%d-", _year);

        if(_month < 10) printf("0%d-",_month);

        else printf("%d-",_month);

        if(_day < 10) printf("0%d ",_day);

        else printf("%d ",_day);

        printf("%s/n",weekdays[_weekday]);

    }

    

   // long time = clock(); 

    //printf("time = %ld ms/n",time);

    

    return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值