HDU 5167 Fibonacci(DFS暴力搜索)

Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1905    Accepted Submission(s): 479


Problem Description
Following is the recursive definition of Fibonacci sequence:
斐波那契数列的递归定义如下:

Fi=01Fi1+Fi2i = 0i = 1i > 1

Now we need to check whether a number can be expressed as the product of numbers in the Fibonacci sequence.
现在我们需要判断一个数是否能表示为斐波那契数列中的数的乘积。

 

Input
There is a number  T  shows there are  T  test cases below. ( T100,000 )
有多组数据,第一行为数据组数TTT \leq 100,000T100,000)。
For each test case , the first line contains a integers n , which means the number need to be checked. 
对于每组数据有一个整数nn,表示要判断的数字。
0n1,000,000,000
 

Output
For each case output "Yes" or "No".
对于每组数据,如果可以输出“Yes”,否则输出"No"。
 

Sample Input
  
  
3 4 17 233
 

Sample Output
  
  
Yes No Yes
 

Source
 

解题思路:由于斐波那契数列变换比较快,在1000000000内的斐波那契数只有不到50,可以对每一个n搜索n的斐波那契因数,如果找得到斐波那契因数,输出Yes,否则输出No。


代码如下:

#include <cstdio>
#include <iostream>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <string>
#include <algorithm>
#include <vector>
#include <deque>
#include <list>
#include <set>
#include <map>
#include <stack>
#include <queue>
#include <numeric>
#include <iomanip>
#include <bitset>
#include <sstream>
#include <fstream>
#include <limits.h>
#include <ctime>
#define debug "output for debug\n"
#define pi (acos(-1.0))
#define eps (1e-6)
#define inf (1<<28)
#define sqr(x) (x) * (x)
#define mod 1000000007
using namespace std;
typedef long long ll;
typedef unsigned long long ULL;
ll f[55];
bool DFS(ll n,ll m)
{
    if(n<=6)
        return true;
    for(ll i=3; i<=m; i++)
    {
        if(n%f[i])
            continue;
        if(DFS(n/f[i],i))
            return true;
    }
    return false;
}
int main()
{
    ll i,j,k,n,t;
    f[0]=0ll;
    f[1]=1ll;
    for(i=2; i<=45; i++)
        f[i]=f[i-1]+f[i-2];
    /*
    for(i=0;i<=50;i++)
        printf("%I64d\n",f[i]);
    */
    scanf("%I64d",&t);
    while(t--)
    {
        scanf("%I64d",&n);
        if(DFS(n,45))
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值