Arctic Network 2349(最小生成树的第k长边)

32 篇文章 1 订阅
31 篇文章 0 订阅
Arctic Network
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 13225 Accepted: 4291

Description

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel.
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).

Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

Sample Input

1
2 4
0 100
0 300
0 600
150 750

Sample Output

212.13
#include<stdio.h>
#include<string.h>
#include<math.h>
#define mx 0x3f3f3f3f
#include<algorithm>
using namespace std;
double g[510][510],x[510],y[510],dis[510];
double a[510];
int vis[510];
int n,m;
void prim()
{
	int i,j,k,v,s=0;
	double min;
	memset(vis,0,sizeof(vis));
	memset(a,0,sizeof(a));
	for(i=1;i<=m;i++)
	{
		dis[i]=g[1][i];
	}
	dis[1]=0;
	vis[1]=1;
	for(j=1;j<=m;j++)
	{
		min=mx;
		k=1;
		for(i=1;i<=m;i++)
		{
			if(!vis[i]&&dis[i]<min)
			{
				min=dis[i];
				k=i;
			}
		}
		vis[k]=1;
		a[s++]=min;
		for(i=1;i<=m;i++)
		{
			if(!vis[i]&&dis[i]>g[k][i])
			{
				dis[i]=g[k][i];
			}
		}
	}
	sort(a,a+s);
	printf("%.2lf\n",a[m-n-1]);
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int i,j;
		scanf("%d%d",&n,&m);
		memset(g,mx,sizeof(g));
		for(i=1;i<=m;i++)
		{
			scanf("%lf %lf",&x[i],&y[i]);
		}
		for(i=1;i<=m;i++)
		{
			for(j=i+1;j<=m;j++)
			{
				g[i][j]=g[j][i]=sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
			}
		}
		prim();
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值