Tian Ji -- The Horse Racing 2287 (好题 数学逻辑)

Tian Ji -- The Horse Racing
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 12344 Accepted: 3807

Description

Here is a famous story in Chinese history. 
That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others. 

Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser. 

Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian. 

Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match. 

It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China? 

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching... 

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses -- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem. 

In this problem, you are asked to write a program to solve this special case of matching problem.

Input

The input consists of up to 50 test cases. Each case starts with a positive integer n ( n<=1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian's horses. Then the next n integers on the third line are the speeds of the king's horses. The input ends with a line that has a single `0' after the last test case.

Output

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

Sample Input

3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0

Sample Output

200
0
0
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
int a[1010],b[1010];
int main()
{
	int n,i,j,t;
	int tzk,tzm,kzk,kzm;
	while(scanf("%d",&n),n)
	{
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		for(i=0;i<n;i++)
			scanf("%d",&b[i]);
		sort(a,a+n);
		sort(b,b+n);
		tzk=kzk=n-1;
		tzm=kzm=0;
		t=0;
		while(tzk>=tzm)//将田忌的所有马都遍历一遍 
		{
			if(a[tzk]>b[kzk])//田忌的快马比国王的快马快 
			{
				tzk--;//让这两匹马比赛 
				kzk--;
				t+=200;//田忌胜 
			}
			else if(a[tzk]==b[kzk])// ***这块是重点*** 如果田忌与国王快马一样快 
			{
				if(a[tzm]>b[kzm])//先让他俩的慢马比,如果田忌的慢马快 
				{
					tzm++;//让这两匹马比赛 
					kzm++;
					t+=200;//那么田忌胜 
				}
				else if(a[tzm]==b[kzm])//如果这两匹慢马也一样快 
				{
					if(a[tzm]<b[kzk])//则比较田忌慢马和国王快马,若田忌慢 
					{
						kzk--;
						tzm++;
						t-=200;
					}
					else//否则表示这几匹马都一样快,即为平局 
					{
						kzk--;
						tzm++;
						t+=0;
					}
				}
				else//否则表示田忌慢马比国王慢马慢 
				{
					kzk--;
					tzm++;
					t-=200;
				}
			}
			else//如果田忌快马比国王快马慢 
			{
				kzk--;//让田忌慢马消耗国王快马 
				tzm++;
				t-=200;
			}
		}
		printf("%d\n",t);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值