Knots 2407 (规律题)

40 篇文章 1 订阅
23 篇文章 0 订阅

Knots

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 220    Accepted Submission(s): 150


Problem Description
An even number N of strands are stuck through a wall. On one side of the wall, a girl ties N/2 knots between disjoint pairs of strands. On the other side of the wall, the girl's groom-to-be also ties N/2 knots between disjoint pairs of strands. You are to find the probability that the knotted strands form one big loop (in which case the couple will be allowed to marry). 

For example, suppose that N = 4 and you number the strands 1, 2, 3, 4. Also suppose that the girl has created the following pairs of strands by tying knots: {(1, 4), (2,3)}. Then the groom-to-be has two choices for tying the knots on his side: {(1,2), {3,4)} or {(1,3), (2,4)}.
 

Input
The input file consists of one or more lines. Each line of the input file contains a positive even integer, less than or equal to 100. This integer represents the number of strands in the wall.
 

Output
For each line of input, the program will produce exactly one line of output: the probability that the knotted strands form one big loop, given the number of strands on the corresponding line of input. Print the probability to 5 decimal places.
 

Sample Input
  
  
4 20
 

Sample Output
  
  
0.66667 0.28377
//题意:
/*
有N根绳子(N为偶数)穿过一堵墙,一小女孩在墙的一边打了N/2个结
在墙的另一边也打了N/2个结,并且打结的两根线是不相交的,问打完结后
去掉墙后能组成一个大环的概率。 
//一个找规律题,递推公式是a[i]=a[i-2]*(i-2)/(i-1); 
*/ 
#include<stdio.h>
double a[110];
int main(){
	int n;
	int i,j;
	a[2]=1.0;
	for(i=4;i<=100;i+=2)
		a[i]=a[i-2]*(1.0*(i-2)/(i-1));
	while(scanf("%d",&n)!=EOF)
	{
		printf("%.5lf\n",a[n]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值