zoj 1100&& poj2411 Mondriaan's Dream (dfs&&枚举&&状态压缩dp)好题

Mondriaan's Dream

Time Limit: 10 Seconds      Memory Limit: 32768 KB

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways.

Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!

Input Specification

The input file contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

Output Specification

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.

Sample Input

1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output

1
0
1
2
3
5
144
51205


 

//看大神http://www.xuebuyuan.com/2019062.html的博客,虽然很简短,但还是没理解,先贴上代码和思路

#include<cstdio>
#include<cstring>
long long dp[12][12][1<<12];  //行|列|状态
bool judge(int sta)
{
    while(sta)
    {
        if(sta&1)
        {
            if((sta&3)!=3)
                return false;
            sta>>=2;
        }
        else
            sta>>=1;
    }
    return true;
}
void init()
{
    memset(dp,0,sizeof(dp));
    for(int m=1;m<=11;m++)
    {
        dp[0][m][(1<<m)-1]=1LL;
        for(int i=0;i<11;i++)  //枚举行数
        {
            for(int mask1=0;mask1<(1<<m);mask1++)  //枚举第i行的状态
            {
                int mask=(~mask1)&((1<<m)-1);//第i行状态的补集,即下一行一定要填的
                for(int mask2=mask;mask2<(1<<m);mask2=(mask2+1)|mask) //枚举第i+1行的状态
                {
                    if(judge(mask2^mask))//mask2^mask表示把i+1行所在上一行空着格子的列的格子排除后要填横放砖块的位置
                        dp[i+1][m][mask2]+=dp[i][m][mask1];
                }
            }
        }
    }
}

int main()
{
    init();
    int a,b;
    while(scanf("%d%d",&a,&b),a|b)
    {
        printf("%lld\n",dp[a][b][(1<<b)-1]);
    }
}


 

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值