poj Pick-up sticks 2653 (计算几何 直线相交的判断)

Pick-up sticks
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 11334 Accepted: 4249

Description

Stan has n sticks of various length. He throws them one at a time on the floor in a random way. After finishing throwing, Stan tries to find the top sticks, that is these sticks such that there is no stick on top of them. Stan has noticed that the last thrown stick is always on top but he wants to know all the sticks that are on top. Stan sticks are very, very thin such that their thickness can be neglected.

Input

Input consists of a number of cases. The data for each case start with 1 <= n <= 100000, the number of sticks for this case. The following n lines contain four numbers each, these numbers are the planar coordinates of the endpoints of one stick. The sticks are listed in the order in which Stan has thrown them. You may assume that there are no more than 1000 top sticks. The input is ended by the case with n=0. This case should not be processed.

Output

For each input case, print one line of output listing the top sticks in the format given in the sample. The top sticks should be listed in order in which they were thrown.

The picture to the right below illustrates the first case from input.

Sample Input

5
1 1 4 2
2 3 3 1
1 -2.0 8 4
1 4 8 2
3 3 6 -2.0
3
0 0 1 1
1 0 2 1
2 0 3 1
0

Sample Output

Top sticks: 2, 4, 5.
Top sticks: 1, 2, 3.

Hint

Huge input,scanf is recommended.
 
//题意:
给你n个直木棍的起点和终点,问那几个木棍不与其他木棍相交,若相交只取最上面的那个木棍。
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define N 100010
#define E 1e-6
using namespace std;
struct zz
{
	double x,y;
	double xx,yy;
}a[N];
double judge(zz a,double x,double y) 
{
	return (x-a.x)*(a.yy-a.y)-(y-a.y)*(a.xx-a.x);
}
int check(zz a,zz b)//判断相交 
{
	if(max(a.x,a.xx)<min(b.x,b.xx))
		return 0;
	if(max(b.x,b.xx)<min(a.x,a.xx))
		return 0;
	if(max(a.y,a.yy)<min(b.y,b.yy))
		return 0;
	if(max(b.y,b.yy)<min(a.y,a.yy))
		return 0;
	if(judge(a,b.x,b.y)*judge(a,b.xx,b.yy)>E)
		return 0;
	if(judge(b,a.x,a.y)*judge(b,a.xx,a.yy)>E)
		return 0;
	return 1;
}
int main()
{
	int n,m,i,j;
	while(scanf("%d",&n),n)
	{
		for(i=1;i<=n;i++)
			scanf("%lf%lf%lf%lf",&a[i].x,&a[i].y,&a[i].xx,&a[i].yy);
		printf("Top sticks: ");
		for(i=1;i<n;i++)
		{
			for(j=i+1;j<=n;j++)
			{
				if(check(a[i],a[j]))
					break;
			}
			if(j==n+1)//没有与i号木棍相交的,则输出它本身 
				printf("%d, ",i);
		}
		printf("%d.\n",n);
	}
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值