hdoj Surround the Trees 1392 (凸包)

59 篇文章 0 订阅
4 篇文章 0 订阅

Surround the Trees

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9158    Accepted Submission(s): 3508


Problem Description
There are a lot of trees in an area. A peasant wants to buy a rope to surround all these trees. So at first he must know the minimal required length of the rope. However, he does not know how to calculate it. Can you help him?
The diameter and length of the trees are omitted, which means a tree can be seen as a point. The thickness of the rope is also omitted which means a rope can be seen as a line.



There are no more than 100 trees.

Input
The input contains one or more data sets. At first line of each input data set is number of trees in this data set, it is followed by series of coordinates of the trees. Each coordinate is a positive integer pair, and each integer is less than 32767. Each pair is separated by blank.

Zero at line for number of trees terminates the input for your program.

Output
The minimal length of the rope. The precision should be 10^-2.

Sample Input
  
  
9 12 7 24 9 30 5 41 9 80 7 50 87 22 9 45 1 50 7 0

Sample Output
  
  
243.06
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
struct zz
{
	int x;
	int y;
}q[1010],p[1010];
int cmp(zz a,zz b)
{
	if(a.x==b.x)
		return a.y<b.y;
	return a.x<b.x;
}
int judge(zz a,zz b,zz c)
{
	return (b.x-a.x)*(c.y-a.y)-(c.x-a.x)*(b.y-a.y);
}
int main()
{
	int t,i,j;
	int n,r;
	while(scanf("%d",&n),n)
	{
		for(i=0;i<n;i++)
			scanf("%d%d",&q[i].x,&q[i].y);
		sort(q,q+n,cmp);
		int k1=0;
		for(i=0;i<n;i++)
		{
			while(k1>1&&judge(p[k1-2],p[k1-1],q[i])<=0)
				k1--;
			p[k1++]=q[i];
		}
		int k2=k1;
		for(i=n-1;i>=0;i--)
		{
			while(k1>k2&&judge(p[k1-2],p[k1-1],q[i])<=0)
				k1--;
			p[k1++]=q[i];
		}
		k1--;
		double sum=0;
		for(i=0,j=1;i<k1;i++,j++)
		{
			sum+=sqrt((p[i].x-p[j].x)*(p[i].x-p[j].x)+(p[i].y-p[j].y)*(p[i].y-p[j].y));
		}
		if(n>2)
			printf("%.2lf\n",sum);
		else
			printf("%.2lf\n",sum/2);//如果点的个数为二,只有一条线,不能组成闭合图,所以在计算时多算了一遍,在这块要除2. 
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值